Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Where you define the external ID?

on 8/22/13, 5:19 AM 1,599 views

problem: 2013-08-21 21:13:53,686 2176 ERROR suisse_trade_new openerp.netsvc: No such external ID currently defined in the system: resource.timesheet_group1

Where does this error message mean?

I have just created a new database. The problem always comes back - demo data I have not cleared

it is only the MRP module, or what can I do?

On 8/22/13, 6:23 AM

What this probably means:


In module resource, xml record with id timesheet_group1 does not exist.

and what can I do? updates the module does not work - same error under the resources I find any useful settings

on 8/22/13, 6:40 AM

It looks like a bug that needs to be solved. That non-existent id is referenced somewhere, and causes the error. You'll have to dive in the code...

on 8/22/13, 6:52 AM

Unfortunately I have no idea where to look. 's Too bad - I thought OpenERP is the perfect system. But unfortunately it does not seem to run properly. I must be getting to use another system

on 8/22/13, 7:17 AM

I have just made one test account on http://my.openerp.com - there everything works. how can that be? the errors are deliberately built to sell the SaaS solution??

on 8/22/13, 7:24 AM

I ran a search through OpenERP7 source code, and refernces to the id we are talking about is found in few places, but only on demo data XMLs (MRP demo also, so this might be it). It might very well be you will not experience this problem on database without demo data.

on 8/22/13, 8:21 AM

And in addition, the actual id is in module named "resource" demo data. If not yet, try to install Resource module.

on 8/22/13, 8:25 AM

Problem is - I can not create a database as normal way. Because OE takes automatically template1. Then comes the problem with UTF-8. Funny thing is - I've already template1 deleted and template0 copied and renamed to template1 - same problem. I do not understand it. I can only copy a database from template0 to create a new database - but then the demo data is in it. if i will Delete the demo data by hand - getting error messages.

BTW: is there a way to re-create the templates-databases from PostgreSQL whit a SQL-query or insert the right Dump? maybe there is the error..

on 8/22/13, 3:43 PM

You can set which db template to use in OpenERp config file. And databases can be created from OpenERP interface, with demo data and without. Just start server, and at login screen go to "manage databases". There you can create a new database by template specified in config file, and you can choose to load demo data or not.

on 8/23/13, 3:06 AM

i have change the config: db_template = template0 ...but the same problem - (pity you can download the no longer forum - to write here is really troublesome) ---- Error: DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII) - HINT: Use the same encoding as in the template database, or use template0 as template. I think I need a new template database - but still could not find how to do that

on 8/23/13, 5:37 AM

I can confirm. With an empty db on postresql, OpenERP always fires the same error:ValueError: No such external ID currently defined in the system: resource.timesheet_group1

on 9/30/13, 12:26 PM

OK. I think I have the solution. The problem is that OpenErp has to initialize itself the DB. If you create a new db fromn within the psql prompt and/or the phppgadmin frontend, OpenERP fire out the resource error. To solve this, proper OpenERP configuration for user/pwd db administration is required. Once set up everything in the right manner, clear all old dbses, restart openerp service, let the db creation wizard happens -from the browser- and that's all. magic happens. Try it out and let me know. Please, test this procedure, and spread these informations if this solution works even for you

on 10/2/13, 6:26 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 8/22/13, 5:19 AM
Seen: 1599 times
Last updated: 3/16/15, 8:10 AM