Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Where to specify the parameter of wkhtmltopdf in Odoo?

By
Drees Far
on 12/18/15, 10:09 AM 803 views

Hello !!

Can anyone help me know where to find the path where can i specify the

wkhtmltopdf in Odoo.

Thanks a lot in advance.

Best Regards.


0
Armando Villalta
On 2/25/16, 1:14 PM

Hi,

I havent tried in odoo v9 but I did had same issue on odoo v8. What I did was the following:

1)Technical > Parameters >System Parameters (similar in odoo v9)

2)You should have 2 keys in there with the following values :

a)key= web.base.url  value = http://localhost:8069

b)key = report.url      value = http://127.0.0.1:8069/

I search a lot in this.What understand is that sometimes server take more time to proccess data than the wkhtmltopdf so thats why you get blank page.So now with this you tell the system something like to "send" data separately when  printing reports in pdf format.

Note: If you dont have both keys you can easily create them in the same window,just hit create and write down each key and its corresponding value and save.

Let me know if it helps.

Armando

0
Zied Haffoudhi
On 2/25/16, 9:48 AM

Hi, 

I have the same problem. 

I'm using Windows 7, Odoo9, I installed wkhtmltopdf and this is the path : C:\Program Files\wkhtmltopdf

Report_type="qweb-html" is working perfectly, but when I use report_type="qweb-pdf" I get the pdf with data but without Css !

I added report.url = http://localhost:8069 and

webkit_path = C:\Program Files\wkhtmltopdf

 in "Settings" > "System Parameters".

But it's still the same problem.

Anyone have any idea how to solve this please ? Thanks.


0

Parikshit

--Parikshit--
939
| 6 3 8
Ahmedabad, India
--Parikshit--

Working as an OpenERP/Odoo developer both experience in web and addons. you can contact me at:

E-mail : parikshitvaghasiya@gmail.com

Blog : parikshitvaghasiya.blogspot.in

Stackoverflow : http://stackoverflow.com/users/5089106/parikshit-vaghasiya

Parikshit
On 12/18/15, 11:48 AM

Hello,


You can set parameter in setting > system parameter 

And create :

name : report.url

urlhttp://127.0.0.1:8069 

Hope this will help you !!

would you plz give me an example for the name. i didnt understand it very well :/

Drees Far
on 12/18/15, 1:34 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/18/15, 10:09 AM
Seen: 803 times
Last updated: 2/25/16, 1:14 PM