Odoo Help


Where to edit navbar (navigation) of the treehouse theme (or any other new Odoo theme)?

S. Edelman
on 5/30/15, 5:07 AM 1,451 views

I can't find where to edit the navigation in the treehouse theme. This question may be valid to other new themes too. I would like to get rid of the link "SIGN IN" there and I also would like to get the language selection on that row and then in the end get rid of the whole preheader.

I have read a lot of the forum discussion but they seem to relate to the older navigation items, not these new themes. Now I can't find those same referred xml codes anymore in these new themes. How is the navbar appearing to the theme, from where?

@S. Edelman,

Have you tried the 'Customize' menu at the top right of the screen when you are logged in as administrator on the frontend of the website?

I don't have the theme personally, but there should be an option to tick labelled 'Show Sign In' or something like that.

Are you running Odoo on the SaaS (online Odoo.com hosted version), or are you running Odoo on your own server?

Luke Branch
on 5/30/15, 6:32 AM

@luke, where have you seen this button ? Have you already see it on a website or only in the code... ???

Jérémy Kersten (jke)
on 5/30/15, 9:44 AM
S. Edelman
On 5/30/15, 8:31 AM

I'm running the system in my own server indeed. In the customize menu I can't find such label "Show Sign In" but I found the "Template ID: website.homepage" in HTML editor now. It is actually there but if I upgrade / customize my theme otherwise to the server, this part will be overridden and I must do it again. Thus I would like to find the real xml template that brings this code online.

I've searched with the key pieces of the code in the whole theme package but can't find any other than styling for the navbar. 


If I remove the user "Public", actually EVERYBODY CAN SEE it, also administrator even if logged (then shows both "sign in" and "administrator" menu item). Now I put that only the "administrator" can see and now public can't see but the admin sees both "sign in" and "administrator". Anyway better like this that the public won't see it.


Jérémy Kersten (jke)

--Jérémy Kersten (jke)--

| 3 3 5
Jodoigne, Belgium
--Jérémy Kersten (jke)--

Jérémy is a member of the core R&D team since september 2013. He developed several projects for OpenERP version 8 including the eCommerce, the Google Calendar synchronization and the new product variants/configurator. Now, he manages Odoo website and themes for saas.

Jérémy Kersten (jke)
On 5/30/15, 10:10 AM


Seems that this options has been broken...

So, to make it working you can go in:

Settings -> Technical -> User Interface -> Views

Find the template : "Show Sign In" (id= website.show_sign_in)

Go into tab "Groups" and remove "Public"

Now edit the arch and update the view to set groups on the both li.

I will fix it in V8, so at next update, that will be fixed 


Fixed in commit 1bc3283

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 5/30/15, 5:07 AM
Seen: 1451 times
Last updated: 5/31/15, 2:59 AM