Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

where are POS sales stored (and how)?

By
Taha Ch
on 3/31/14, 3:46 PM 1,098 views

After my first test last week with the POS module and "closing" the day by printing a report, I am now failing to print a report for sales I complete (with cash) at the POS, already tried several sellers and closed, open sessions etc. I toured the database with pgadmin, and many tables I looked at looked scarily empty after sales. It looks possible that somehow I damaged the ability of the server to record sales, though I did not edit any tables or source, how can I find a way out? Thanks!

1

Thierry Godin

--Thierry Godin--
1516
| 8 7 8
Collegien, France
--Thierry Godin--

..

Thierry Godin
On 3/31/14, 6:51 PM

POS orders are stored in pos_order and pos_order_line tables in the DB but bank statements are stored in account_bank_statement and account_bank_statement_line

Sale module is another module. Sales from POS are not stored in sale_order/sale_order_line

Thanks, it looks like completing POS sales does not enter any data in my pos_tables. However my database is not all broken, I was able to create new sellers and products etc. Any idea how I can go about troubleshooting this? It looks like I may have found a bug or a feature! I am on Windows 8.1

Taha Ch
on 4/1/14, 4:41 AM

Maybe orders are not well sent to database ??? If the Led (top right of POS) turns red with a number, It is because orders are stuck in the browser and are not sent to DB

Thierry Godin
on 4/1/14, 6:49 AM

right! I think I remember seeing the green color up there, but not recently, and "closing" already shows 0,00, so nothing is transferred to the database. I am getting the suspicion it could be a firewall thing, even though other parts of the OpenERP work well. Any ideas how to troubleshoot my red light, considering I can pgadmin in the database?

Thanks!

Taha Ch
on 4/1/14, 2:58 PM

Take a look at the openerp-server.log, It may contain some indications.

Thierry Godin
on 4/1/14, 8:21 PM

thanks, I have not found the answer yet, but browsing the POS files I was surprised I needed some Windows permission to see them, the addon must have been installed with higher priviledges than the server itself. But since I can run POS, these permissions are probably not the answer. I will be switching to Linux in a couple of days, maybe that will work a bit better.

Taha Ch
on 4/2/14, 1:22 PM
0
Taha Ch
On 4/1/14, 2:58 PM

right! I think I remember seeing the green color up there, but not recently, and "closing" already shows 0,00, so nothing is transferred to the database. I am getting the suspicion it could be a firewall thing, even though other parts of the OpenERP work well. Any ideas how to troubleshoot my red light, considering I can pgadmin in the database?

Thanks!

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/31/14, 3:46 PM
Seen: 1098 times
Last updated: 3/16/15, 8:10 AM