Odoo Help

0

what is the problem with this /etc/init.d/ocb-7.0-server startscript?

By
gunnar
on 7/13/14, 3:39 AM 1,622 views

I am trying to install "ocb 7.0" (the community backport version of Openerp 7.0) on a ubuntu 14.04 using following this (http://www.schenkels.nl/2014/05/install-odoo-v7-from-github-ubuntu-14-04-lts-formerly-openerp/)
howto. I have tweaked it for the ocb-server (git clone https://www.github.com/OCA/OCB --branch 7.0 ocb)

I get to the point to start the server manually. which works fine. The server is started. I can acces is through my browser (getting to the "add databse" page)

Check if the server works

sudo su odoo

python /opt/odoo/odoo/openerp-server --config=/etc/odoo-server.conf

 

just once I use the /etc/init.d/ocb-7.0-server startscript I run into the following error

: No such file or directory line 1:  #!/bin/sh
:not found/ocb-7.0-server: line 13: $'\r': command not found
:not found/ocb-7.0-server: line 18: $'\r': command not found
:not found/ocb-7.0-server: line 21: $'\r': command not found
:not found/ocb-7.0-server: line 24: $'\r': command not found
:not found/ocb-7.0-server: line 27: $'\r': command not found

: numeric argument required : line 30: exit: 0

actually I thought the numbers mentioned 1, 13, 13, ... would refer to the lines of the script but apart from line 1 they are all empty

in my browser under [ip-of-the-server]:8069 I get a:

handler not found

 

this is the original script

#!/bin/sh

### BEGIN INIT INFO

# Provides: odoo-server

# Required-Start: $remote_fs $syslog

#Required-Stop: $remote_fs $syslog

# Should-Start: $network

#Should-Stop: $network

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# Short-Description: Business Applications

# Description: ODOO Business Applications.

### END INIT INFO

 

PATH=/bin:/sbin:/usr/bin

DAEMON=/opt/odoo/odoo/openerp-server

NAME=odoo-server

DESC=odoo-server

 

# Specify the user name (Default: openerp).

USER=odoo

 

# Specify an alternate config file (Default: /etc/odoo-server.conf).

CONFIGFILE="/etc/odoo-server.conf"

 

# pidfile

PIDFILE=/var/run/$NAME.pid

 

# Additional options that are passed to the Daemon.

DAEMON_OPTS="-c $CONFIGFILE"

[ -x $DAEMON ] || exit 0

[ -f $CONFIGFILE ] || exit 0

checkpid() {

[ -f $PIDFILE ] || return 1

pid=`cat $PIDFILE`

[ -d /proc/$pid ] && return 0

return 1

}

 

case "${1}" in

start) echo -n "Starting ${DESC}: "

start-stop-daemon --start --quiet --pidfile ${PIDFILE} \

--chuid ${USER} --background --make-pidfile \

--exec ${DAEMON} -- ${DAEMON_OPTS}

echo "${NAME}."

;;

stop)

echo -n "Stopping ${DESC}: "

start-stop-daemon --stop --quiet --pidfile ${PIDFILE} \

--oknodo

echo "${NAME}."

;;

 

restart|force-reload)

echo -n "Restarting ${DESC}: "

start-stop-daemon --stop --quiet --pidfile ${PIDFILE} \

--oknodo

sleep 1

start-stop-daemon --start --quiet --pidfile ${PIDFILE} \

--chuid ${USER} --background --make-pidfile \

--exec ${DAEMON} -- ${DAEMON_OPTS}

echo "${NAME}."

;;

*)

N=/etc/init.d/${NAME}

echo "Usage: ${NAME} {start|stop|restart|force-reload}" >&2

exit 1

;;

 

esac

exit 0

I have changed the DEAMON, USER and CONFIG FILE to match my situation. Any hints what I else needs to be done

the startscript has is owned by root:root

EDIT: found out that there is another symptom when I start the server manually. The password for the database creation is still 'admin' (eventhough I have provided a different one in the ocb-7.0-server.config file). Not sure whether these two issues are related in any way, but maybe it gives another hint about what the problem might be

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 7/13/14, 3:39 AM
Seen: 1622 times
Last updated: 3/16/15, 8:10 AM