Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

What happens if I change the openerp system user password?

By
Tony
on 3/20/13, 9:30 AM 1,739 views

My system was running smoothly until I changed the openerp system password. I am not talking about any database user or password. I changed the openerp system (linux) user password and now I cannot load "Settings" inside of OpenERP. I am receiving the following error:

OpenERP Client Error Uncaught Error: QWeb2 -template['SearchView.filters']: Runtime Error: TypeError: dict.filter.visible is not.......

The last part gets cut off. I cannot see a similar message in the logs. Could this be related to the password change? If not any ideas on how I can fix this would be appreciated.

Cheers

what openerp version ? have you tried to set password back to old one ? what happens ?

peterm
on 3/20/13, 10:16 AM

I have a similar problem too. TypeError: Object [object Object] has no method 'visible' when I want to go to Settings in top menu.

Radomil Urbánek
on 3/20/13, 11:36 AM

Its a problem at the Openerp website. See below

Tony
on 3/20/13, 2:24 PM
0
Paulo Matos
On 3/20/13, 10:39 AM

Hi there. I am having exactly the same error on OpenERP 7. Since I am learning the functional part of OpenERP, today I have decided to delete the demo database and create a new one. Deleted the database directly from pgAdmin III and when I started OpenERP 7, the system asked me to create a new database. Everything runs fine and after logged in into the system I get this error. I do not remember if used the same password like the old database but I believe the password is the same.

The error I get is: " OpenERP Client Error

OpenERP Client Error Uncaught Error: QWeb2 -template['SearchView.filters']: Runtime Error: TypeError: dict.filter.visible is not a function

localhost:8096/web/webclient/js:2445 "

At the beggining I thought to be a problem on the instalation files and reinstalled everything again and after creating a new database on the clean new instalation the same error occurs.

I fully reinstalled PostgreSQL and OpenERP 7 from the all in one setup package. The conection to openerp database via pgAdmin III iworks fine. What could be the problem?

Thank you and regards.

Paulo Matos

Perhaps I found what is the problem. I found on https://answers.launchpad.net/openobject-server/+question/224716 a post with an asnwer from user Grzegorz that there is an error with the https://apps.openerp.com. There is a local file named apps.js that calls this url on line 66. This is not a problem from installation and/or database.

EuroGold, Paulo Matos
on 3/20/13, 11:46 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/20/13, 9:30 AM
Seen: 1739 times
Last updated: 3/16/15, 8:10 AM