Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Website is broken (GET 404s) with a (completely) fresh Installation of Odoo v8

By
IT GlowMe
on 11/16/14, 3:46 PM 2,318 views

I try to host Odoo v8 on a shard-hosting server and after installation I only get this part of the website:

It's looking like this in the awesome Network Monitor of Firefox:


Here's a small snippet from the log - pretty similiar looking:

2014-11-16 16:04:35,811 31860 INFO None werkzeug: 127.0.0.1 - - [16/Nov/2014 16:04:35] "GET /web/static/lib/jquery.ui.notify/css/ui.notify.css HTTP/1.1" 404 -
2014-11-16 16:04:35,826 31860 INFO None werkzeug: 127.0.0.1 - - [16/Nov/2014 16:04:35] "GET /base/static/src/css/modules.css HTTP/1.1" 404 -
2014-11-16 16:04:35,827 31860 INFO None werkzeug: 127.0.0.1 - - [16/Nov/2014 16:04:35] "GET /web/static/src/css/base.css HTTP/1.1" 404 -

Here's the config file:

    [options]
    addons_path = /home/me/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/addons,/home/me/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/addons
    admin_passwd = super-secret-pw
    auto_reload = False
    csv_internal_sep = ,
    data_dir = /home/me/.local/share/Odoo
    db_host = False
    db_maxconn = 64
    db_name = False
    db_password = False
    db_port = False
    db_template = template1
    db_user = glowme
    dbfilter = .*
    debug_mode = False
    demo = {}
    email_from = False
    geoip_database = /usr/share/GeoIP/GeoLiteCity.dat
    import_partial =
    limit_memory_hard = 2684354560
    limit_memory_soft = 2147483648
    limit_request = 8192
    limit_time_cpu = 60
    limit_time_real = 120
    list_db = True
    log_db = True
    log_handler = [':INFO']
    log_level = debug
    logfile = /home/me/odoo_log.txt
    logrotate = True
    longpolling_port = 62072
    max_cron_threads = 2
    osv_memory_age_limit = 1.0
    osv_memory_count_limit = False
    pg_path = None
    pidfile = None
    proxy_mode = True
    reportgz = False
    secure_cert_file = server.cert
    secure_pkey_file = server.pkey
    server_wide_modules = None
    smtp_password = False
    smtp_port = 25
    smtp_server = localhost
    smtp_ssl = False
    smtp_user = False
    syslog = False
    test_commit = False
    test_enable = False
    test_file = False
    test_report_directory = False
    timezone = False
    translate_modules = ['all']
    unaccent = False
    without_demo = False
    workers = 0
    xmlrpc = True
    xmlrpc_interface =
    xmlrpc_port = 62069
    xmlrpcs = True
    xmlrpcs_interface =
    xmlrpcs_port = 62071

I used this official tutorial to set it up, though I had to change a few things, because of the restrictions of shared-hosting.

One of these restricitions is, that you have to request a port, so I used an `.htaccess` file, in a directory `/var/www/virtual/me/subdomain.example.tld`:

    RewriteEngine On
    RewriteRule (.*) http://localhost:62069/$1 [P]

It didn’t work as tunneling the port didn't either.

And here is the way Uberspace.de handles Python and Python modules (Unfortunately only in german, but I hope it helps anyways).

 

[UPDATE 1]:

I tried reinstalling it and now I get the following error:

2014-11-17 19:29:16,183 28126 INFO None werkzeug: 127.0.0.1 - - [17/Nov/2014 19:29:16] "GET / HTTP/1.1" 500 -
2014-11-17 19:29:16,191 28126 ERROR None werkzeug: Error on request:
Traceback (most recent call last):
  File "/home/glowme/lib/python2.7/Werkzeug-0.9.6-py2.7.egg/werkzeug/serving.py", line 177, in run_wsgi
    execute(self.server.app)
  File "/home/glowme/lib/python2.7/Werkzeug-0.9.6-py2.7.egg/werkzeug/serving.py", line 165, in execute
    application_iter = app(environ, start_response)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/service/server.py", line 280, in app
    return self.app(e, s)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/service/wsgi_server.py", line 216, in application
    return application_unproxied(environ, start_response)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/service/wsgi_server.py", line 202, in application_unproxied
    result = handler(environ, start_response)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1215, in __call__
    return self.dispatch(environ, start_response)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1189, in __call__
    return self.app(environ, start_wrapped)
  File "/home/glowme/lib/python2.7/Werkzeug-0.9.6-py2.7.egg/werkzeug/wsgi.py", line 588, in __call__
    return self.app(environ, start_response)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1327, in dispatch
    self.setup_db(httprequest)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1273, in setup_db
    httprequest.session.db = db_monodb(httprequest)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1399, in db_monodb
    dbs = db_list(True, httprequest)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 1373, in db_list
    dbs = dispatch_rpc("db", "list", [force])
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/http.py", line 100, in dispatch_rpc
    result = dispatch(method, params)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/service/db.py", line 70, in dispatch
    return fn(*params)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/service/db.py", line 313, in exp_list
    with closing(db.cursor()) as cr:
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/sql_db.py", line 569, in cursor
    return Cursor(self.__pool, self.dbname, self.dsn, serialized=serialized)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/sql_db.py", line 181, in __init__
    self._cnx = pool.borrow(dsn)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/sql_db.py", line 460, in _locked
    return fun(self, *args, **kwargs)
  File "/home/glowme/lib/python2.7/openerp-8.0_c7d8e97-py2.7.egg/openerp/sql_db.py", line 520, in borrow
    result = psycopg2.connect(dsn=dsn, connection_factory=PsycoConnection)
  File "/home/glowme/lib/python2.7/psycopg2-2.5.4-py2.7-linux-x86_64.egg/psycopg2/__init__.py", line 164, in connect
    conn = _connect(dsn, connection_factory=connection_factory, async=async)
OperationalError: FATAL:  no pg_hba.conf entry for host "::1", user "odoo", database "postgres", SSL off

Here's how my pg_hba.conf looks:

local   all             all                                     md5
local   all             odoo                                    trust
host    all             all             127.0.0.1/32            trust

 

@IT GlowMe, What is your database name on your shared hosting? I usually see this page when Odoo cannot establish a database connection.

Luke Branch
on 11/17/14, 3:30 AM

Upvote for using Uberspace

Fnordbedarf
on 11/17/14, 10:16 AM

After a Git pull and a start of the server with -u all I have the same problem, with an befor running server. No change in config. I think there is something wrong with the code on git.

Tobias Frankl
on 11/17/14, 3:49 PM
1
TS
On 11/17/14, 10:58 AM

if I may suggest, try please to replace your config file with something less sophisticated, like, for example:

[options]
; This is the password that allows database operations:
; admin_passwd = admin
db_host = localhost
db_user = openerp
db_password = openerp
addons_path = /usr/lib/python2.7/dist-packages/openerp/addons

In most case I've run odoo, above was sufficient. To be honest never seen config similar to your before, maybe there is something wrong inside? If, as you've mentioned, you are about to start from scratch (fresh installation), simplest config would do the work.

 

regards

Tomasz

Thanks. While this didn't directly brought me to my solution, it helped me realise my mistake: I forgot to reload the server

IT GlowMe
on 11/17/14, 3:43 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 11/16/14, 3:46 PM
Seen: 2318 times
Last updated: 3/16/15, 8:10 AM