Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Webkit problems

By
Dale
on 6/1/14, 3:40 PM 1,006 views

Hi 

I have been having tremendous problems getting webkit running in OpenERP V7. I have followed all the instruction documents I could find. I have removed and re-installed numerous times and I have tried V9 and V11 RC1 of WKHTMLTOPDF. I am desperate to get it up and running as since I have uninstalled I no longer have the default partner reports in Accounting.

Currently I have WKHTMLTOPDF V9 static installed and the Financial report webkite module. I can produce reports using "Webkit Debug" but then I have no logo or header / footer. When I take debug off I get Error 127 - no diagnosis.

Please advise me if you have any information on this problem

Thanks

Have you added the various webkit addons and added those to your conf file?

Richard
on 6/4/14, 4:41 AM

Have you uploaded the logo?

ahmad
on 6/27/14, 12:24 PM
1
Timothy Solomon
On 7/1/14, 3:41 AM

Are you running on windows or linux? I found version 9 worked best. you can get it from the old google code repo: https://code.google.com/p/wkhtmltopdf/downloads/list?can=1 

test running wkhtmltopdf from the command line to make sure that it is working. If you have problems with that try http://stackoverflow.com/questions/9604625/wkhtmltopdf-cannot-connect-to-x-server/9685072

If it is working on the command line but not in openerp, check the logs and see if there is more information. Also check the settings in Settings > Technical > Webkit logos / headers. If you install a fresh new database, does the webkit reporting work in that? 

Good luck :)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 6/1/14, 3:40 PM
Seen: 1006 times
Last updated: 3/16/15, 8:10 AM