Odoo Help

3

3
12 Answers
0
Aristóbulo Meneses Belgium
4/15/16, 3:39 AM

Just in case anyone else gets this error, here is how I solved it for an Odoo 6.1 instance:


  1. Go to http://download.gna.org/wkhtmltopdf/0.12/0.12.1/ and download the right package for your distribution.

  2. Install it with dpkg -i (on Debian or Ubuntu) 

  3. Go to System Parameters and check your webkit_path, it should match your wkhtmltopdf binary path. To know where is it on your system: which wkhtmltopdf


Hope it helps.

0
Avatar

Serpent Consulting Services Pvt. Ltd. India

--Serpent Consulting Services Pvt. Ltd.--
Serpent Consulting Services Pvt. Ltd.
http://www.serpentcs.com
5053
| 7 6 10
Gandhinagar, India
--Serpent Consulting Services Pvt. Ltd.--

Serpent Consulting Services Pvt. Ltd. is an Official Odoo Partner, working on Odoo ever since 2007, experience of 11+ years and witnessed the growth of Odoo.

We are a team of 80+ experts on various verticals. Our portfolio of products can be seen at http://www.serpentcs.com and http://www.serpentcs.in

Our Expertise and Services:

  • Odoo Support

  • Odoo Development

  • Odoo Training

  • Odoo Migration

  • Odoo Implementation

  • Odoo Consulting

Our 290+ Apps on Appstore : https://apps.odoo.com/apps/modules/browse?author=Serpent Consulting Services Pvt. Ltd.

Thanks.

Serpent Consulting Services Pvt. Ltd. India
10/11/13, 4:13 PM

One has to make sure to use wkhtmltopdf version 0.11 min.

Thanks.

0
Avatar

Daniel Reis Portugal

--Daniel Reis--
3976
| 8 9 11
Linda-a-Velha, Portugal
--Daniel Reis--

Author of the "Odoo Development Essentials" book.

Applications Manager at Securitas Portugal

Github: https://github.com/dreispt

Twitter; @reis_pt


Daniel Reis Portugal
7/25/13, 7:14 AM

You might have encountered Bug#1102991. If this is so, a workaround is to grant write access to the addons directory.

PS: you didn't give a proper traceback to let us figure out exactly where the proble is ...

2 Comments
Mohammad Zi Malaysia
7/25/13, 7:34 AM

@Daniel, Thanks for your feedback and I updated the question just now.

Mohammad Zi Malaysia
7/25/13, 7:40 AM

I have given full access right to all users of my server to read and write in the addons directory but the error still exist.

0
Avatar

Grover Menacho Bolivia

--Grover Menacho--
WebVision Enterprise Systems
https://www.linkedin.com/in/hmen89/
3025
| 7 8 10
La Paz, Bolivia
--Grover Menacho--

Odoo Developer

Grover Menacho Bolivia
10/11/13, 6:34 PM
1 Comment
Mathias Neef Germany
10/12/13, 4:47 AM

Thank you for your reply. I've done all things from the guide before your post, so I checked twice. Everything looks right. wkthmltopdf have full permissions to every user. But the error stays. The debug modus for html output works fine.

0
Laurent Olivier France
10/13/13, 4:59 AM

Hi,

Be aware of giving the path WITH the name of the wkhtmltopdf in the webkit_path Eg /usr/local/bin/wkhtmltopdf-i386 in my case.

Hope it helps

0
Mathias Neef Germany
10/9/13, 10:11 AM

Same error. I'm running 7.0-20130918-231035 on Debian 7.1 and have installed report_webkit and account_financial_report_webkit. wkhtmltopdf (static/amd64) lays in /usr/local/bin. webkit_paht is defined to /usr/local/bin.

Error is:

financial.reports.webkit: cannot remove file /tmp/webkit.tmp.BNXnn5.pdf: [Errno 2] No such file or directory: '/tmp/webkit.tmp.BNXnn5.pdf'
2013-10-09 10:46:40,268 5930 ERROR bemavino_live_20130919 openerp.service.web_services: Exception: [Errno 13] Permission denied
Traceback (most recent call last):
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/service/web_services.py", line 712, in go
    (result, format) = obj.create(cr, uid, ids, datas, context)
  File "/opt/openerp/server/openerp/addons/report_webkit/webkit_report.py", line 340, in create
    result = self.create_source_pdf(cursor, uid, ids, data, report_xml, context)
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/report/report_sxw.py", line 513, in create_source_pdf
    return self.create_single_pdf(cr, uid, ids, data, report_xml, context)
  File "/opt/openerp/server/openerp/addons/account_financial_report_webkit/report/webkit_parser_header_fix.py", line 233, in create_single_pdf
    pdf = self.generate_pdf(bin, report_xml, head, foot, htmls)
  File "/opt/openerp/server/openerp/addons/account_financial_report_webkit/report/webkit_parser_header_fix.py", line 121, in generate_pdf
    status = subprocess.call(command, stderr=stderr_fd)
  File "/usr/lib/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1259, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied
2013-10-09 10:46:40,497 5930 ERROR bemavino_live_20130919 openerp.netsvc: 13
Permission denied
(<type 'exceptions.OSError'>, OSError(13, 'Permission denied'), <traceback object at 0x56d0878>)
Traceback (most recent call last):
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/netsvc.py", line 292, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/service/web_services.py", line 654, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/service/web_services.py", line 760, in exp_report_get
    return self._check_report(report_id)
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/service/web_services.py", line 738, in _check_report
    netsvc.abort_response(exc, exc.message, 'warning', exc.traceback)
  File "/opt/openerp/openerp-7.0-20130918-231035/openerp/netsvc.py", line 71, in abort_response
    raise openerp.osv.osv.except_osv(description, details)
except_osv: (u'13\nPermission denied', (<type 'exceptions.OSError'>, OSError(13, 'Permission denied'), <traceback object at 0x56d0878>))

So it seems that permission to /tmp folder is denied. Tried with full access to /tmp and /addons folder wiht no changes to the error. So I can't find out what went wrong at the moment.

I don't think that this is Bug#1102991.

1 Comment
Mathias Neef Germany
10/10/13, 6:00 AM

Now I reproduced this error on a newly made local system with test data.

Ask a Question
Writer
Tag
Keep Informed
3 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now