Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


View vs Object mismatch...

on 2/12/13, 9:46 AM 651 views

I have a custom module which extends objects and defines view. When I install the module I get a message saying that a field requested by a view is missing in the object definition. However, this is wrong, because if I do this it works:

First I install the module without the views (I remove the xml reference from __openerp__.py). All goes well and the objects are as expected.

Then I upgrade the module with the references put back in __openerp__.py.

If I do this it works fine. But if I try to do it all in one step I get the issue. It gives me the impression that the system is trying to create the views before updating the objects.... is this possible?

I've progressed on this. It is my account.invoice object view which causes the issue. Still investigating.

on 2/13/13, 5:27 AM

Is this in OpenERP v7.0 ?

Camptocamp SA
on 2/23/13, 9:02 PM

Vasiliy Birukov

--Vasiliy Birukov--
| 6 6 8
Russian Federation
--Vasiliy Birukov--

Help develop and implement any project on base Odoo.

Vasiliy Birukov
On 2/26/13, 12:46 AM

Delete all *.pyo files from folder of module and restart server.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 2/12/13, 9:46 AM
Seen: 651 times
Last updated: 3/16/15, 8:10 AM