Odoo Help

0

Version 10.0: localhost refused to connect

By
Tony Cook
on 10/7/16, 12:27 PM 1,923 views

I downloaded a copy of the Windows .exe for Version 10.0e to evaluate locally before rolling out on our server (we already have an Enterprise contract), and after a completed installation I immediately get a "localhost refused to connect" error in my browser when the install tries to navigate to localhost:8069. From what I've read, this may be an error with Postgres refusing the connection due to password problems or incorrect service user?

When I look at which services are running, PostgreSQL_for_Odoo is running fine, but odoo-server-10.0 will not start (saying "The system cannot find the file specified").

Thanks in advance.

Hello Artem,

Thanks for your tip. I didn't change the default directory (Program Files (x86)\Odoo 10.0e), but the registry entry did still contain the directory of a previous installation (which I had already uninstalled and removed the directories for). Unfortunately, even after correcting the value and restarting, localhost refuses to connect.

Tony Cook
on 10/7/16, 4:05 PM

Is the error still the same?

If so check file permission, path, policies.

On my computer 10.0 works.

Artem
on 10/7/16, 8:19 PM
1
Artem
On 10/7/16, 3:56 PM

Let me guess you have changed the default installation directory?

If so change the odoo service setting in the registry of 'ImagePath' in HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\odoo-server-10.0

YES! this the correct answer. Thanks.

OdooTec, Hesham ELMAHDY
on 3/28/17, 8:26 AM
0
Yacov Mosbacher
On 5/19/17, 10:31 AM

his is supposed to be a comment but you need 8 karma for that and I'm new to this forum. Artem's answer worked for me too! Thanks!!   Just wanted to give a step by step fix in Windows 10. 

  • Open Services (by clicking Start and writing Services)

  • Find the odoo service, verify that it is not running and press Start. You should  get the error message.

  • Open RegEdit (click the Start button and write regedit) and navigate to
     HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\odoo-server-10.0

  • Double click on odoo-server-10.0

  • Change the path to: (including quotes)
    "C:\Program Files (x86)\Odoo 10.0e\service\win32_service.exe"
    and click OK

  • Go back to services and click start. Everything should now be OK. 

0
Xavier Brochard
On 10/8/16, 6:24 AM

Did you stopped the firewall ?... it's a usual error. First stop it, try to access Oddo and then open the port in the firewall.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 10/7/16, 12:27 PM
Seen: 1923 times
Last updated: 5/19/17, 10:31 AM