Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Value Error for no Reason?

By
evon_dun
on 5/3/13, 8:03 AM 897 views

I just tried to add reports to my modules and restarted openerp server and it gave error then i deleted all the report files i created and updated __openerp.py also. I even tried to delete module and then adding it to addons, cleared chache and restarted openerp server but it still gives the same error all the time. I am stuck now do i need to create it again from scratch?? Error is: ValueError: invalid literal for int() with base 10: 'False'

same module works in another database. why??

evon_dun
on 5/3/13, 8:57 AM
0

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 5/3/13, 5:13 PM

Somehow the installation has an invalid construction, probably from your module. Somewhere you try to convert a value to int, which has the value False, instead of 0.

I have had the same issue myself, and fixed it by restoring a previous version of the DB and than install / upgrade my module after correcting my error.

but i didn't touch my module at all

evon_dun
on 7/4/13, 2:46 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 5/3/13, 8:03 AM
Seen: 897 times
Last updated: 3/16/15, 8:10 AM