Help

2

v8 : Web site images and social networks publication

Avatar
Jean-Marc Dupont

Hi,

I noticed that when we publish a Web site page or a blog post on a social network (linkedin, Google+, Twitter, Facebook, ...) the images in the page or blog are not recognized by the social network, as they are normally for other web sites.

That is VERY annoying, as images are part of social network attractivity

Is there a workaround ?

 

Avatar
Discard
3 Answers
0
Best Answer

Hello Jean,

Here you go!
 

Go to Settings>>Configuration>>Website Settings
 

Click on Website Settings menu you will see all the link of social accounts.

If you don't want to show the icons than remove the links from there than icon will automatically removed from there.

You can set your own account link also.

Hope this will work for you.

Anil (SerpentCS)

 

3 Comments
Avatar
Discard
Avatar
Jean-Marc Dupont
-

Thanks but you didn't get it It's not a problem of social networks icons The problem is When I want to publish a blog post for example on a social network (linkedin, twitter, ...), the image present in the post is not shown in the social network

Avatar
Martin Temmink
-

I have the similar problem. You can partly solved this by including some tags in your html, but... Just make sure that your Facebook sharer parses is using the correct information, you need to (refetch) the url from within Facebook (you can force this by using their debug tool, Search for Facebook object debugger). Otherwise you may have corrected the problem, but because Facebook is using some cache old picture, instead of your new picture.

Avatar
Martin Temmink
-

I have the similar problem. You can partly solved this by including some tags in your html, but... Just make sure that your Facebook sharer parses is using the correct information, you need to (refetch) the url from within Facebook (you can force this by using their debug tool, Search for Facebook object debugger). Otherwise you may have corrected the problem, but because Facebook is using some cache old picture, instead of your new picture.

0
Best Answer

any news on this issue ? 

After digging around it seems there are more troubles --> creating this issue first of all there are redirects and second background images like in the blogposts are not images they are background images and different handled... more ... follows
1 Comment
Avatar
Discard

in the case that text is shown wrongly on a blogpost we found out that its based on the language Options, if you do have installed 2 languages, you get an permanent rewrite. (we are using nginx as proxy) If the second language has no translated text in the blog, facebook for example uses the standard text from the origianal "headline of the snipped" and so the text shown in facebook artikle is wrong cause of the permanent moved for the crawler.... the text of the in our case english page which was not translated is shown not the german one. Workaround if possible: Temporarily solved by disabling the second language and using only one so the permament rewrite is gone for the crawler and the correct text is taken... but the problem is still there..... if you enable again the language. Images shown wrong in the facebook share are still a problem, i cannot assume my customers to edit the html code every time they create a blog entry .... i hope this issue gets solved soon. thanks in advance and hope this info helps too and someone can guess another solution for the wrong texts....

0
Avatar
Jean-Marc Dupont
Best Answer

This is especially the case with blog posts, which is a shame :-(

Any help from Odoo ?

1 Comment
Avatar
Discard
Avatar
Martin Temmink
-

Basically I have the same question: https://www.odoo.com/forum/help-1/question/socal-integration-working-100-or-a-little-less-76399