Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

v8 : Web site images and social networks publication

By
Jean-Marc Dupont
on 9/3/14, 2:31 AM 985 views

Hi,

I noticed that when we publish a Web site page or a blog post on a social network (linkedin, Google+, Twitter, Facebook, ...) the images in the page or blog are not recognized by the social network, as they are normally for other web sites.

That is VERY annoying, as images are part of social network attractivity

Is there a workaround ?

 

0
joachim grubelnik
On 4/15/15, 1:36 PM

any news on this issue ? 

After digging around it seems there are more troubles --> creating this issue first of all there are redirects and second background images like in the blogposts are not images they are background images and different handled... more ... follows

in the case that text is shown wrongly on a blogpost we found out that its based on the language Options, if you do have installed 2 languages, you get an permanent rewrite. (we are using nginx as proxy) If the second language has no translated text in the blog, facebook for example uses the standard text from the origianal "headline of the snipped" and so the text shown in facebook artikle is wrong cause of the permanent moved for the crawler.... the text of the in our case english page which was not translated is shown not the german one. Workaround if possible: Temporarily solved by disabling the second language and using only one so the permament rewrite is gone for the crawler and the correct text is taken... but the problem is still there..... if you enable again the language. Images shown wrong in the facebook share are still a problem, i cannot assume my customers to edit the html code every time they create a blog entry .... i hope this issue gets solved soon. thanks in advance and hope this info helps too and someone can guess another solution for the wrong texts....

joachim grubelnik
on 5/6/15, 3:27 AM
0
Jean-Marc Dupont
On 9/4/14, 6:12 AM

This is especially the case with blog posts, which is a shame :-(

Any help from Odoo ?

Basically I have the same question: https://www.odoo.com/forum/help-1/question/socal-integration-working-100-or-a-little-less-76399

Martin Temmink
on 2/13/15, 7:56 PM
0

Anil R. Kesariya

--Anil R. Kesariya--
4321
| 6 5 8
Gandhinagar, India
--Anil R. Kesariya--
ERP Consultant

Key Skill
-
Technical & Functional Expert
Anil R. Kesariya
On 9/4/14, 6:23 AM

Hello Jean,

Here you go!
 

Go to Settings>>Configuration>>Website Settings
 

Click on Website Settings menu you will see all the link of social accounts.

If you don't want to show the icons than remove the links from there than icon will automatically removed from there.

You can set your own account link also.

Hope this will work for you.

Anil (SerpentCS)

 

Thanks but you didn't get it It's not a problem of social networks icons The problem is When I want to publish a blog post for example on a social network (linkedin, twitter, ...), the image present in the post is not shown in the social network

6 IT, Jean-Marc Dupont
on 9/4/14, 9:24 AM

I have the similar problem. You can partly solved this by including some tags in your html, but... Just make sure that your Facebook sharer parses is using the correct information, you need to (refetch) the url from within Facebook (you can force this by using their debug tool, Search for Facebook object debugger). Otherwise you may have corrected the problem, but because Facebook is using some cache old picture, instead of your new picture.

Martin Temmink
on 2/20/15, 6:59 PM

I have the similar problem. You can partly solved this by including some tags in your html, but... Just make sure that your Facebook sharer parses is using the correct information, you need to (refetch) the url from within Facebook (you can force this by using their debug tool, Search for Facebook object debugger). Otherwise you may have corrected the problem, but because Facebook is using some cache old picture, instead of your new picture.

Martin Temmink
on 2/20/15, 6:59 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 9/3/14, 2:31 AM
Seen: 985 times
Last updated: 4/23/15, 11:06 AM