Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

v8 purchase order not auto updating Product Cost Price

By
Scott Hart
on 10/4/15, 12:08 AM 604 views

My Odoo instance is setup and I understand everything else but here's the problem

1) I have set up Purchase Price and Sales Price list correctly and they work if I manually define the Cost Price and Supplier Cost Price in each product.

2) I've defined FIFO, Account Stock Properties and Account Properties under the product category all / saleable. Defined as:

Income Account – “110000 Sales of Goods”

Expense Account – “230100 Goods in Transit”

Stock Input Account – “230200 Stock”

Stock Output Account – “510100 Cost of Goods Sold”

Stock Valuation Account – “230200 Stock”

3) Based the product on Stockable and Real Price...

I believe I've set everything up correctly, but I cannot get Odoo to automatically update the Cost Price with the incoming Purchase Order. PLEASE HELP! This is driving me crazy... I've figured everything else out and this is stumping me.

0

Akhil P Sivan

--Akhil P Sivan--
3423
| 5 3 6
Kochi, India
--Akhil P Sivan--

Interested in exploring Odoo both technically & functionality wise.

email-id : akhilpsivan01@gmail.com

Akhil P Sivan
On 10/4/15, 4:12 AM

Hi Scott,

Please check this post about similar issue. And make sure you did all the configurations mentioned:

https://www.odoo.com/forum/help-1/question/average-cost-updates-automatically-68846 

Might be something wrong with the configurations. Which is the accounting that you use?

The only thing I had different was I hadn't checked landed cost because I didn't need that feature. I've now checked it and still not working. :( As far as accounting Internal Category; I've defaulted to All/ Saleable (as I've defined Account Properties, Account Stock Properties and FIFO to be implemented on every product we sell.) Inventory Valuation is set to Real Time (automated) and then the accounting as mentioned above. I've got it to work 1 time before but I couldn't isolate why or what I did different. I copied and recreated the product exactly as it was, but nothing. Purchased and Ordered the product exactly the same but I couldn't get even that original product to do it again. I have noticed that once I receive the product, no updated information is showing up under Product > Procurements > Suppliers. On version 9 I've noticed the information shows up no problem.

Scott Hart
on 10/4/15, 9:20 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/4/15, 12:08 AM
Seen: 604 times
Last updated: 10/4/15, 4:12 AM