Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

V7 and Proxy mode failed on partner list

By
Mind And Go
on 8/27/13, 5:45 AM 2,635 views

Hy all of you,

I've configured my OpenERP behind an apache Proxy. Here is my conf (http hide because of publishing links is forbidden for me):

 ServerName openerp.mydomain.local

ProxyRequests Off
ProxyPreserveHost On

ProxyPass / "localhost:8069/"
ProxyPassReverse / "localhost:8069"
ProxyErrorOverride Off
SetEnv proxy-nokeepalive 1 

<Proxy *>
    Order deny,allow
    Allow from all
</Proxy>

<Location />
    Order allow,deny
    Allow from all
</Location>

When I reach the "openerp.mydomain.local" openerp runs like a charm. Unfortunately when I try to show the partners list (24000) I have the following error in my browser :

XmlHttpRequestError NOT FOUND
404 Not Found
Not Found The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again.

I read many post and activate proxy mode in my conf file Showing the kanban of partners causes no trouble. Going anywhere else causes no troubles, installing new plugins causes no troubles.... The problem seems to come only form the partner list. Here is the apache logs :

[Tue Aug 27 09:33:20 2013] [error] [client 192.168.2.24] client denied by server configuration: proxy:localhost:8069/web/dataset/call_kw, referer: openerp.mydomain.local/?db=upa_dev&ts=1377588722676
[Tue Aug 27 09:33:20 2013] [error] [client 192.168.2.24] client denied by server configuration: proxy:localhost:8069/web/dataset/call_kw, referer: openerp.mydomain.local/?db=upa_dev&ts=1377588722676
[Tue Aug 27 09:33:24 2013] [error] [client 192.168.2.24] client denied by server configuration: proxy:localhost:8069/web/static/lib/jquery.ui.bootstrap/css/custom-theme/images/ui-icons_222222_256x240.png, referer: openerp.mydomain.local/web/webclient/css?db=upa_dev

I tried many and many confs without no success. Any help would be appreciated.

Running on CentOS 6 OpenERP v7.0 no iptables, no selinux.

regards

Hy folks,

Is anybody as an idea as a solution for this issue? Could it come from the referer? Is there any conf in apache or in the openerp.conf to adapt

Mind & Go, Mind And Go
on 10/20/13, 9:05 AM

What I observed is that the problem is coming when the screen is coming grey with the waiting icon.

Mind & Go, Mind And Go
on 10/20/13, 9:52 AM

And also a many2many performance issue : https://bugs.launchpad.net/openerp-web/+bug/1265274

Mind & Go, Mind And Go
on 4/24/14, 7:00 AM
0
Mind And Go
On 5/14/14, 5:20 PM

Hy

In the end I certainly found a reason. My apache proxy was using some mod_security modules and mod_evasive.
I deactivate them and it works perfectly.

Yet many2many_tags still very slow performance through web.

0
Antonio M. Vigliotti
On 6/11/14, 11:17 AM

Hello,

My configuration works and it is different from yours in these sections:

  • I enabled keepalive (keepalive=on in ProxyPass directive)
  • I disabled sessione reuse (disablereuse=on in ProxyPass directive)
  • Not declared allow in <location/> </location>

Here bit of code:

ProxyPass / http://localhost:8069/ disablereuse=on timeout=600 keepalive=On

<location / >

    ProxyPassReverse /

</location>

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/27/13, 5:45 AM
Seen: 2635 times
Last updated: 3/16/15, 8:10 AM