Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

V6.1 Bazaar Package not Found

By
Christian Eichert
on 1/23/14, 4:47 PM 1,149 views

I am struggling with the ubuntu/debian version installed using the latest 6.1 server and 6.1 client. The Fleet management Module (Author Vertel) fire the following Errors:

1) Bazaar Package not Found ! But the bzr package is in the latest version.

2) cannot marshal None unless allow_none is enabled I found a lot of people asking this but no solution posted The best one seem to be a comment that allow should be False not None and Allow_none should be not true. But it makes no sense. Can someone solve that ?

Environment Information : 
System : Windows-post2008Server-6.1.7601-SP1
OS Name : nt
Operating System Release : post2008Server
Operating System Version : 6.1.7601
Operating System Architecture : 32bit
Operating System Locale : de_DE.cp1252
Python Version : 2.6.5
OpenERP-Client Version : 6.1.1
Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
  File "/opt/openerp/server/openerp/wsgi/core.py", line 80, in xmlrpc_return
    response = xmlrpclib.dumps((result,), methodresponse=1, allow_none=0, encoding=None)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1132, in dumps
    data = m.dumps(params)
  File "/usr/lib/python2.6/xmlrpclib.py", line 677, in dumps
    dump(v, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 699, in __dump
    f(self, value, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 780, in dump_struct
    dump(v, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 699, in __dump
    f(self, value, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 780, in dump_struct
    dump(v, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 699, in __dump
    f(self, value, write)
  File "/usr/lib/python2.6/xmlrpclib.py", line 703, in dump_nil
    raise TypeError, "cannot marshal None unless allow_none is enabled"
TypeError: cannot marshal None unless allow_none is enabled

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/23/14, 4:47 PM
Seen: 1149 times
Last updated: 11/1/16, 8:58 AM