Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

utf8 codec can't decode byte error while importing master data csv from windows OS ?

By
muthunaveen
on 3/22/14, 4:20 AM 3,442 views

Hi Friends,

Facing an different scenario altogether. I had a master data csv created from the original MS-excel document. I have ensure it has got comma separator and UTF-8 encoding while saving it. When i try to import into customers, suppliers or products i am getting an error

Blockquote

utf8' codec can't decode byte 0x92 in position 15: invalid start byte

Blockquote

but when i try to import the same csv from ubuntu it succeeds in validation and import as well. Looks strange.

Can some one tell me where is the issue ? any one facing a similar issue of mine ?

Thanks in advance for your suggestions.

Regards Naveen

0
Alain ZIO
On 3/23/14, 3:00 PM

Hi Mutu,
Importing datas with MS Excel most of the time gives you this error except when you first export some datas from Openerp.
To solve this problem while using MS Excel just change the encoding methode from UTF-8 to windows-1252 and use "Semicolon" as separator , even if you are 100% sure that MS Excel has saved your file in .csv
Best regards

Thanks for your answer Alain. Will try doing the same, but doing the same in libre office seems to be a permanent solution for this.

muthunaveen
on 3/24/14, 2:00 AM
0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 3/23/14, 7:23 PM

Hi,

I've also faced this situation.

And the solution is:

Under windows don't use MS Excel, but use LibreOffice or OpenOfficeOrg, when converting to csv.

Hi and yes i understood now, converting an Excel to csv in windows has an issue so tat openerp cannot recognise the ascii format of the texts it seems, if am correct. Anyways am doing the alternate approach as u suggested as i have another OS i.e Ubuntu besides Windows 8. But dont wish to switch the OS every time i want to import the data. Thanks a lot for your answer. Good day ahead!.

muthunaveen
on 3/24/14, 1:30 AM

I have another small problem which am facing i.e i want to import all the customers with its respective contacts at one shot, but am unable to do so. I am not sure which is the relative field for the "contacts column. I tried using all t combinations as i know but all failed returning error. I am able to import the customers witout contacts but not with both at one shot. Can you tell me whats the right fields to be used. ? Would of great help to me in that case.

muthunaveen
on 3/24/14, 1:43 AM

hi i have cracked it no need to worry, btw t key is to have each contact as a separate line item under a Parent company and adding a new column related company will do the needful at one shot.

muthunaveen
on 3/25/14, 2:20 AM
0

Ray Carnes

--Ray Carnes--
15717
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 3/22/14, 3:05 PM

Using Excel to create UTF8 CSV files is problematic (sometimes saving as XLS instead of XLSX first produces different results, sometimes the UTF8 files are not in fact UTF8).

I have better luck using a different text editor, or using a codepage conversion program.

Also, don't overlook that some conversion may be happening when you move your files between operating systems.

References:

http://notepad-plus-plus.org/

http://sourceforge.net/projects/cp-converter/

Thanks for the reply Ray, i understood the key now.

muthunaveen
on 3/24/14, 1:58 AM

Ray i have another doubt, am facing issue while importing customers along wt its contacts. I am able to import customers alone wtout any errors but when i tried wt its contacts OE cant recognise the data and giving out error. Not sure am i missing out the right fields to use. Can u let me know if you are aware of the exact fields for customer and contacts.

muthunaveen
on 3/24/14, 2:02 AM

hi i have cracked it no need to worry, btw t key is to have each contact as a separate line item under a Parent company and adding a new column related company will do the needful at one shot.

muthunaveen
on 3/25/14, 2:21 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/22/14, 4:20 AM
Seen: 3442 times
Last updated: 3/16/15, 8:10 AM