Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

/usr/bin/env : node: No such file or directory in ovoo v9

By
kartik
on 11/5/15, 4:07 AM 2,455 views

i installed odoo v9 in ubuntu 12.04

used .deb file for odoo installation

after that odoo theme not render properly and it give following error  

/usr/bin/env : node: No such file or directory in ovoo v9

after i follow this question

and give command

ln -s /usr/bin/nodejs /usr/bin/node

so it gives following error

This error occured while compiling the bundle 'web.assets_backend' containing:

- /website/static/src/less/import_bootstrap.less

- /web/static/src/less/variables.less

- /web/static/src/less/enterprise_compatibility.less

- /web/static/src/less/utils.less

- /web/static/src/less/modal.less

- /web/static/src/less/notification.less

- /base_import/static/src/less/import.less

- /web_tip/static/src/less/tip.less

- /web_calendar/static/src/less/web_calendar.less

- /web_diagram/static/src/less/diagram_view.less

- /web_kanban/static/src/less/kanban_dashboard.less

- /web_kanban/static/src/less/kanban_view.less

- /web_settings_dashboard/static/src/less/dashboard.less

i check for nodejs version is

nodejs -v it return v0.10.25


how can i solve this error

1

Ermin Trevisan

--Ermin Trevisan--
3524
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 11/5/15, 4:32 AM

thanks it works for me

kartik
on 11/5/15, 4:54 AM
0
Santanu Singh
On 6/9/16, 8:22 AM

Option 1 mention in the following link worked for me. 

http://www.hostingadvice.com/how-to/install-nodejs-ubuntu-14-04/


Use apt-get to install the build-essential package:

sudo apt-get install build-essential checkinstall

Employ a similar process to get libssl-dev:

sudo apt-get install libssl-dev

You can install and update Node Version Manager, or nvm, by using cURL:

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.31.0/install.sh | bash

You will be asked to close and reopen the terminal. To verify that nvm has been successfully installed after you reopen the terminal, use:

command -v nvm

That command will output nvm if the installation worked.

To download, compile and install the latest version of Node:

nvm install 5.0

In any new shell, you’ll need to tell nvm which version to use:

nvm use 5.0

To set a default Node.js version to be used in any new shell, use the alias default:

nvm alias default node

0
Steven Furick
On 4/21/16, 9:37 AM

The link in the previous answer is 404 here's what I found that worked for me on Ubuntu 14.04. I copy and pasted the steps one at a time to get things working. 


The NodeJS and NPM packages in the Ubuntu 14.04 repository can not be used because they are outdated.

Follow the instructions from the NodeJS Website:

curl -sL https://deb.nodesource.com/setup_0.10 | sudo bash -
sudo apt-get install -y nodejs
sudo npm install -g npm

Then install Less and accessories:

 sudo npm install -g less less-plugin-clean-css

As you can see, I install version 0.10 of the deb and not anything else.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/5/15, 4:07 AM
Seen: 2455 times
Last updated: 6/9/16, 8:22 AM