Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

user rights [Closed]

By
Yaroslav
on 2/11/13, 7:28 AM 1,013 views

The Question has been closed

by
Yaroslav
on 02/11/2013 09:28:06

I'm asking this more general question taking as base this other one I've asked couple days ago.

I've come to a point where I have two identical enviroments configured. One is a virtualized Ubuntu 12.04LTS on my local/development pc and the other one is on our server. Both configurations have same parameters, companies, user rights, everything. I've manually checked each and everyone of the available options. Off course, maybe there is a hidden checkbox that I could not know off as I'm a newbie on OpenERP. But I have verified everything that is visible on my current configurations.

Then, with one user on my local enviroment I can create new suppliers, customers, etc, "partners" generally speaking. But on the server whenever I try to create a new supplier I get a warning telling me that the user doesn't have enough rights to accomplish the action. I click OK and continue to create the supplier and click APPLY. The supplier is created without problems and I'm able to delete it afterwards.

Can be possible that this issue is related to user rights on UBUNTU and not in the OpenERP platform? I've ran out of options, I don't know what else to try.

EDIT

Is a reported bug, check comments on answer on referenced question. Or go directly to multi company Access Denied Document type: Partner, Operation: read where the bug was reported and is followed up by other users.

Please, try to provide a revelant question subject...

Antonin Bourguignon (abo)
on 2/11/13, 7:52 AM

I'm having a user rights configuration problems and I can't get it done. I've come to a point where I think is a ubuntu related question. Is this possible? If yes, can anyone provide a possible solution? I've read the FAQs and I believe this is not a poll or argumentative question and can be useful

Yaroslav
on 2/11/13, 8:03 AM
0
Tom Arnst
On 2/11/13, 8:33 AM

It's probably the same questions as posted here : help.openerp.com/question/480/openerp7-new-user-with-full-rights-unable-to-create-new-partners/ I think it's a bug...! we have the same on a none multi-company instance of OE

And this is a comment to my question, not an answer. And the user is the same: me. Read again the first sentence of my question. If you consider is a duplicate, flag it.

Yaroslav
on 2/11/13, 9:10 AM

I think it's a bug...! is de best answer I can give you at the moment. Sorry... it's no solution, but could maybe saved you some time.

Tom Arnst
on 2/11/13, 9:23 AM

Yes, seems to be a bug. I got the answer from user 12492 on the referenced question just minutes after I posted this new question.

Yaroslav
on 2/11/13, 9:27 AM

mmm... so the answer was correct..!

Tom Arnst
on 2/11/13, 9:30 AM

Part of it should be a comment to my question, not an answer. And, as in this case, if it is a bug, should point to a location where to either solve it, post it, reference it or follow it. None of the action was made. I will just remove the -1

Yaroslav
on 2/11/13, 9:33 AM

Interesting that you could go on and save after the error. My experience has been Portal Access/Share Access/Multi-Company access have effected certain rights like you describe. I am doing build number 2 now so going very carefully before I create the second user. Given the nearly 3 weeks since posted perhaps this has been fixed in the Nightly Builds. I have not read that it has been though.

Landis Arnold
on 3/1/13, 6:10 PM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 2/11/13, 7:28 AM
Seen: 1013 times
Last updated: 3/16/15, 8:10 AM