Odoo Help

0

Urgent help needed. 500 internal server error, 2 hours before launch

By
Prowler
on 3/21/16, 5:36 AM 624 views

I am a one lucky mf..

I somehow fucked the database just before giving the application to my clients. I didn't do anything drastic, didn't change any code. So now if I try to visit the url I get internal server error.

This is the log from /var/log/odoo

http://pastebin.com/5TH0PS17

The problem is just on one database. If I visit the url of the other db one the same instance of odoo it loads normally.

Any help would be more than welcome!

try to upgrade all modules. may be it will helps you.

Jignesh Mehta
on 3/21/16, 5:55 AM

You seem to have fucked up your sales teams and/or the access rights or user assignment to sales teams. You should at least try to update the CRM module.

Ermin Trevisan
on 3/21/16, 6:43 AM

hm.. how do you update a module if you can't access the backend. the only thing I could do is to run ./odoo.py -update=all ... but i've tried that and it didn't help.. :(

Prowler
on 3/21/16, 7:52 AM

I already created a new database and we are setting this thing up again, but I would still love to know what the hell happened..

Prowler
on 3/21/16, 7:55 AM
0
Prowler
On 3/22/16, 4:25 AM

OMFG IT HAPPENED AGAIN! Can somebody clear this up? Why is this happening to me and how do I prevent this?!?!?!?

EDIT:

So with a help from some Odoo expert that I somehow got on the phone, we solved the problem. I accidentally fucked up one template file and then xml wasn't valid, so the entire thing just crashed.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/21/16, 5:36 AM
Seen: 624 times
Last updated: 3/30/16, 4:59 AM