Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Upon installation of the google_drive module in openERP 7.0

Adam OConnor
on 9/18/13, 4:37 PM 1,077 views

Upon installation of the google_drive module in openERP 7.0, I get this error:

KeyError: 'google.service'

I have seen that others are getting this but haven't seen an answer as to why

Adam OConnor
On 9/18/13, 8:48 PM

OK, I found that google.service is a missing model. It is not being created but it is being referenced by a class in the google_drive module (lines 221 and 226 in google_drive.py). I don't know what this class is or which module should be creating it. I have tried installing google_base_account, google_docs, google_apis modules because there may be dependencies there. None of that worked, however.

I was able to run the Google docs script and successfully generate reports. This is the one at the bottom of the thread and was referenced by Fabrice in this post: help.openerp.com/question/27120/what-is-the-best-way-to-develop-reports-in-open-erp/

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 9/18/13, 4:37 PM
Seen: 1077 times
Last updated: 3/16/15, 8:10 AM