Odoo Help


Update Module List odoo

on 12/11/15, 4:44 AM 3,450 views

How Can i update module list From terminal in

openerp and odoo(v8) ?

Is there any way to achieve this from terminal?

I want to update module list Without Using Webclient.

In this case:

i can't use -u or -i to start server

using -u i am unable to get updated module list actually i want to update module list and that after want to install it using -i module_name



| 6 5 7
Tbilisi, Georgia
On 12/14/15, 5:12 AM

you should pass comma separated list to -u, like module_a,module_b etc:

./odoo.py -d database_name_to_update  -u module_a,module_b,module_c
note that there should NOT be space between module names, just comma. Also, -d option is mandatory, you must specify (using -d) the database name you'd like to update modules in.


if you can't use '-u' because module is not installed yet, then you can use '-i' instead (i.e. install), but if a target module is a fresh new module (usually custom one) and it is not yet added to module list, then I'm afraid to disappoint you but odoo currently does not support module list update from command line, however there is a pretty nice workaround (see the following thread: https://www.odoo.com/forum/help-1/question/how-to-update-module-list-from-command-line-84385). so you'll need to update module list first, and then use "-i" to install new modules.



moulay rachid
on 12/14/15, 1:23 PM

hello Temur, I can't use '-u' as an option because that Particular module is not available in list Thanks

on 12/16/15, 5:16 AM

Hello, Please check the updated answer.

on 12/16/15, 6:09 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 12/11/15, 4:44 AM
Seen: 3450 times
Last updated: 12/17/15, 1:58 AM