Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Uninstall module referencing non existing models

By
Rubén Cabrera
on 6/15/16, 6:11 AM 296 views

Hi!

I am working with a database migrated from v7 to v8.

There is a module I want to uninstall now on v8, but it references the model stock.picking.out, which no longer exists on v8.

When I click on uninstall I get an error which traceback ends with:


File "/opt/odoo/openerp/addons/base/ir/ir_model.py", line 544, in _module_data_uninstall

model_obj = self.pool[model]

File "/opt/odoo/openerp/modules/registry.py", line 102, in __getitem__

return self.models[model_name]

KeyError: u'stock.picking.out'


I tried setting it to uninstalled from SQL, then installing it again and uninstalling, as recommended in a similar question, but the problem persists.


I also modified the module to addapt to the new model structure of stock.picking so I could do the previous steps, and it installs correctly, but when uninstalling I get the same error.


Any ideas?


Thanks a lot!


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/15/16, 6:11 AM
Seen: 296 times
Last updated: 6/15/16, 6:15 AM