Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


unicode console log

on 9/3/15, 2:31 AM 440 views

I has tried to start odoo,  select my language (russian) in preferences and make wrong operation. Log:

 raise osv.except_osv(_('Invalid Action!'), _('In order to delete a confirmed sales order, you must cancel it before!'))
except_orm: (u'\u041d\u0435\u0432\u0435\u0440\u043d\u043e\u0435 \u0434\u0435\u0439\u0441\u0442\u0432\u0438\u0435!', u'\u0414\u043b\u044f \u0442\u043e\u0433\u043e

All ok, but i prefer to see understandable (Cyrillic) symbols instead \uXXX. One way for this i found is changing interface language (preferences -> english).

What i tried (without success):

LANG=C odoo ... 

I'm sure my console supports unicode symbols. 

Maybe i should add any options to /etc/odoo/openerp-server.conf for my purposes?

Thanks in advance.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 9/3/15, 2:31 AM
Seen: 440 times
Last updated: 9/3/15, 2:45 AM