Odoo Help

6
6 Answers
0
SEAN CALLAHAN
5/4/17, 8:48 PM

My issue was a timeout from Nginx.  You might try adjusting the cpu time values in the odoo config file or adjusting 

proxy_connect_timeout

 proxy_send_timeout

 proxy_read_timeout

from nginx which fixed my issue.

2
Tuan
7/20/16, 10:33 AM

any help on this topic ? I faced the same problem with odoo v9 when I click "Save as" button on binary field

0
Abdessalam Mouttaki
2/6/18, 2:54 PM

I faced the same error for Odoo 11 on Ubuntu 16.

I fixed the issue by adding some Odoo 11 dependencies as follow (thanks to Yenthe666 >> https://github.com/Yenthe666) :

# Installing Python 3 + pip3
sudo apt-get install python3 python3-pip

# Install tool packages
sudo apt-get install wget git bzr python-pip gdebi-core -y

# Install python packages
sudo apt-get install python-pypdf2 python-dateutil python-feedparser python-ldap python-libxslt1 python-lxml python-mako python-openid python-psycopg2 python-pybabel python-pychart python-pydot python-pyparsing python-reportlab python-simplejson python-tz python-vatnumber python-vobject python-webdav python-werkzeug python-xlwt python-yaml python-zsi python-docutils python-psutil python-mock python-unittest2 python-jinja2 python-pypdf python-decorator python-requests python-passlib python-pil -y
sudo pip3 install pypdf2 Babel passlib Werkzeug decorator python-dateutil pyyaml psycopg2 psutil html2text docutils lxml pillow reportlab ninja2 requests gdata XlsxWriter vobject python-openid pyparsing pydot mock mako Jinja2 ebaysdk feedparser xlwt psycogreen suds-jurko pytz pyusb greenlet xlrd

# This is for compatibility with Ubuntu 16.04. Will work on 14.04, 15.04 and 16.04
sudo apt-get install python3-suds

# Install other required packages
sudo apt-get install node-clean-css -y
sudo apt-get install node-less -y
sudo apt-get install python-gevent -y


Don't forget to reboot your system.

I hope this will help.


0
Gagea Alexandru
1/8/18, 7:52 AM

I have the same error, however none of the above solutions are working..

0
Avatar

Shameem Babu @ iWesabe

--Shameem Babu @ iWesabe--
GLOBAL CREATIVE CONCEPTS TECH CO LTD
http://www.iwesabe.com
1420
| 6 3 7
KHOBAR, Saudi Arabia
--Shameem Babu @ iWesabe--

  

 iWesabe - ODOO ERP IMPLEMENTATION & CUSTOMIZATION SAUDI ARABIA.



For Queries : pks.shameem@gmail.com ,shameem@iwesabe.com

Activities     :    Youtube

                           Stackoverflow 

Experience

           iWesabe                                ◉

           Axon Communications        ❍

           Cybrosys Technologies        ❍


Shameem Babu @ iWesabe
5/4/17, 10:01 AM

I face the same issue when I download xls of pivot view

I solved by installing xlwt.

# sudo pip install xlwt==1.1.2


0
Andre de Kock
9/6/16, 7:46 AM

I had a similar problem with Pivot Views, when trying to export them to Excel. My solution was:

<pivot>
    <!-- etc. -->
</pivot>

Change to:

<pivot string="My Pivot View">
    <!-- etc. -->
</pivot>

So what you can try is to put a "string" attribute in your Tree View. Worth a shot.

1 Comment
walid redwan
4/1/18, 8:54 AM

Thanks Dear

Ask a Question
Writer
Keep Informed
2 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now