Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Unable to upload image from my computer

By
Nehal
on 4/10/14, 10:52 AM 3,116 views

Hi,

I cannot upload image from my computer while building a website? Can any one help?

Could you be more precise!

Dhinesh - Technical Consultant, Sodexis Inc
on 4/10/14, 10:56 AM

I am editing the website. When I click on change of image, it will give 2 options and one of them is "Upload Image from your computer". When I upload image exists in my computer instead of OpenERP existing images, it does not show the image.

Nehal
on 4/11/14, 2:22 AM

What happens if you try a different browser? Is this version 8. If so, perhaps it is your specific nightly which is defective.

Martin
on 4/14/14, 12:25 PM

I have tried for mozilla and chrome bt same result. I am using development environment by getting branch from bzr.

Nehal
on 4/15/14, 2:24 AM

Any update on this? I'm facing the same problem, when I try to upload an image it doesn't show and I have this error in the logs: http://pastebin.com/raw.php?i=Huz1787C

Interpreta solucions empresarials S.L., Toni Mas
on 4/26/14, 8:56 PM

That soved the issue, thank you for the reply.

Interpreta solucions empresarials S.L., Toni Mas
on 4/28/14, 2:34 AM
2

Nehal

--Nehal--
2090
| 5 2 8
Ahmadabad, India
--Nehal--
Nehal
On 7/3/14, 8:10 AM

I have followed the steps given in comment#4 of link : https://bugs.launchpad.net/openobject-addons/+bug/1251969 as I am using 12.04 Ubuntu. My problem solved by doing that. Hope this may help you.

0
Dawid
On 8/8/15, 5:30 AM

Hi Nehal,

I encountered that issue also in my system. It turned out that it was not related to odoo itself but to NGNIX settings for request file size.

Original post:

http://craftcms.stackexchange.com/questions/2328/413-request-entity-too-large-error-with-uploading-a-file

413 errors occur when the request body is larger than the server is configured to allow. Here’s how you can fix it, depending on your web server:

Apache: Set the LimitRequestBody directive in either your httpd.conf file or a local .htaccess file. (http://stackoverflow.com/a/3719358/1688568)

Nginx: Set the client_max_body_size directive in nginx.conf (http://www.cyberciti.biz/faq/linux-unix-bsd-nginx-413-request-entity-too-large/)

IIS: Set the uploadreadaheadsize config setting (http://blogs.msdn.com/b/jiruss/archive/2007/04/13/http-413-request-entity-too-large-can-t-upload-large-files-using-iis6.aspx)

You also might want to try increasing PHP’s upload_max_filesize and post_max_size settings in php.ini or using the php_value directive in your .htaccess file if you’re using Apache (http://davidwalsh.name/php-values-htaccess).

That helped to solve it on my side. The issue was also that on webiste You will not see the message from HTTP server. You can see it when You try to add files in Settings -> Technical -> Database Structure -> Attachments.

I hope that that will help others too:)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 4/10/14, 10:52 AM
Seen: 3116 times
Last updated: 8/8/15, 5:31 AM