Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Unable to run Odoo v8 using Docker

By
Hesham ELMAHDY
on 11/6/15, 1:11 PM 810 views

I tried to run Odoo v8 docker.

If I add the container id, it runs but does not provide port number. If I enter the port number as follows:

docker run d69ffe949669 -p 127.0.0.1:8069:8069 --name odoo --link
db:db -t odoo

it says:

openerp-server: error: no such option: -p

if I run the entire command without the container id, it runs Odoo v9

Please help me to start Odoo v8

1
Julio Serna
On 11/6/15, 3:09 PM

I think that this ID d69ffe949669 is the id of images,

but, you don't need pass the id there, because you are using -t odoo

try this,

docker run -p 127.0.0.1:8069:8069 --name odoo --link db:db -t odoo

if the container odoo already exists you got something like this,

Error response from daemon: Conflict. The name "odoo" is already in use by container ID_CONTAINER. You have to delete (or rename) that container to be able to reuse that name.

you can find information  here,

https://hub.docker.com/_/odoo/

That was very useful. Many thanks

OdooTec, Hesham ELMAHDY
on 11/9/15, 10:35 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/6/15, 1:11 PM
Seen: 810 times
Last updated: 11/9/15, 10:35 AM