Odoo Help


Unable to install any modules

on 4/8/13, 7:52 AM 1,756 views

Brand new install of windows all in-one-installer (OpenERP 7.0-20130407-232401), but problem existed on previous version too.

Create fresh db.

Try install any module, get "base_setup module appears to be unavailable at the moment."

image description

And module installation fails.

This can't be a general bug as it would surely be listed on launchpad, which it isn't. Must be a configuration thing somehow.

What could cause it?

On 4/8/13, 8:43 AM

Looks like a permissions issue, or security issue with your server. Have you tried installing it in another computer?

Well the service is running as local system, so has full permissions on all the folders etc. Not sure what other security settings could come into play?

on 4/8/13, 9:13 AM

It was a firewall issue. Turns out OpenERP actually fetches something from openERP servers when you install a module. Thanks @Gustavo.

on 4/8/13, 9:15 AM

not a Windows guy, I never had any problem installing it in Linux. Have you tried installing it in another computer?

on 4/8/13, 9:16 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 4/8/13, 7:52 AM
Seen: 1756 times
Last updated: 3/16/15, 8:10 AM