Odoo Help


try to create module but it is not show in openerp

on 12/1/13, 7:57 AM 1,107 views

i try to show moulue in open erp

ALL FILES __init__._py file

import asset_allocation

__openerp__.py file

'name' :'asset_allocation',
'category':'Generic Modules/Others',
'installable': True,


asset_allocation_view.xml xml <openerp> <data>


    Asset Allocation

<record model="ir.ui.view" id="view_asset_allocation_form">
    <field name="name">asset.allocation.form</field>
    <field name="model">asset.allocation</field>
    <field name="type">form</field>
    <field name="arch" type="xml">
        <form string="Asset Allocation">
            <field name="asset_id"/>
            <field name="employee_id"/>
            <field name="asset_status"/>
            <field name="note"/>

<record model="ir.ui.view" id="view_asset_allocation_tree">
    <field name="name">asset.allocation.tree</field>
    <field name="model">asset.allocation</field>
    <field name="type">tree</field>
    <field name="arch" type="xml">
        <tree string="Asset Allocation">
            <field name="asset_id"/>
            <field name="employee_id"/>
            <field name="asset_status"/>
            <field name="note"/>

<record id="action_asset_allocation" model="ir.actions.act_window">
    <field name="name">Asset Allocation</field>
    <field name="type">ir.actions.act_window</field>
    <field name="res_model">asset.allocation</field>
    <field name="view_mode">tree,form</field>

<menuitem id="menu_asset_allocation" parent="menu_finance_assets" action="action_asset_allocation"/>



      from openerp.osv import fields,osv
     class asset_allocation(osv.osv):
       _name = 'asset.allocation'
     _description = 'Asset Allocation'
      _columns = {
     'asset_id': fields.many2one('account.asset.asset', 'Asset', required=True),
    'employee_id': fields.many2one('hr.employee', 'Employee', required=True),
    'asset_status': fields.datetime( 'Status', required=True,),
    'note': fields.text('Note'),


but it is not show in open erp ?where is the problem


Grover Menacho

--Grover Menacho--
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Odoo Developer

Grover Menacho
On 12/1/13, 5:35 PM

First, you have to enable Technical Features for your User.

Then you have to press Update your Module List on Configuration Page.

Now go to Installed Modules and remove Installed from Search Box. You are going to find your module right there if it's is allocated in the correct path

i all do this but not work

on 12/2/13, 7:29 AM

Maybe your addon is not in the addons folder... These are all the steps to do it, and this works for everyone.

GH Mediacloud, Grover Menacho
on 12/2/13, 9:13 AM

I have the same problem. All I do that's not work and I installed my new server for odoo v8. What can I do for that please

on 10/10/14, 4:35 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 12/1/13, 7:57 AM
Seen: 1107 times
Last updated: 3/16/15, 8:10 AM