Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Troublshooting in manufacturing

By
JURINE sarl
on 5/16/14, 2:03 AM 1,278 views

Hi All

i have some troublshooting in lanching manufacturing order, it's ok to create but when i confirm the MO i have the folowing message

could anyone help me?

OpenERP Server Error

Client Traceback (most recent call last): File "/home/openerp/openerp/openerp/addons/web/http.py", line 204, in dispatch response["result"] = method(self, **self.params) File "/home/openerp/openerp/openerp/addons/web/controllers/main.py", line 1139, in exec_workflow return req.session.exec_workflow(model, id, signal) File "/home/openerp/openerp/openerp/addons/web/session.py", line 147, in exec_workflow r = self.proxy('object').exec_workflow(self._db, self._uid, self._password, model, signal, id) File "/home/openerp/openerp/openerp/addons/web/session.py", line 30, in proxy_method result = self.session.send(self.service_name, method, *args) File "/home/openerp/openerp/openerp/addons/web/session.py", line 103, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info) Server Traceback (most recent call last): File "/home/openerp/openerp/openerp/addons/web/session.py", line 89, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/home/openerp/openerp/openerp/netsvc.py", line 292, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/home/openerp/openerp/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, *params) File "/home/openerp/openerp/openerp/osv/osv.py", line 131, in wrapper return f(self, dbname, *args, **kwargs) File "/home/openerp/openerp/openerp/osv/osv.py", line 220, in exec_workflow res = self.exec_workflow_cr(cr, uid, obj, signal, *args) File "/home/openerp/openerp/openerp/osv/osv.py", line 213, in exec_workflow_cr return object._workflow_signal(cr, uid, [res_id], signal)[res_id] File "/home/openerp/openerp/openerp/osv/orm.py", line 3928, in _workflow_signal result[res_id] = wf_service.trg_validate(uid, self._name, res_id, signal, cr) File "/home/openerp/openerp/openerp/workflow/wkf_service.py", line 119, in trg_validate res2 = instance.validate(cr, id, ident, signal) File "/home/openerp/openerp/openerp/workflow/instance.py", line 43, in validate workitem.process(cr, witem, ident, signal, force_running, stack=stack) File "/home/openerp/openerp/openerp/workflow/workitem.py", line 60, in process ok = _split_test(cr, workitem, activity['split_mode'], ident, signal, stack) File "/home/openerp/openerp/openerp/workflow/workitem.py", line 157, in _split_test if wkf_expr.check(cr, workitem, ident, transition,signal): File "/home/openerp/openerp/openerp/workflow/wkf_expr.py", line 80, in check return _eval_expr(cr, ident, workitem, transition['condition']) File "/home/openerp/openerp/openerp/workflow/wkf_expr.py", line 57, in _eval_expr ret = eval(line, env, nocopy=True) File "/home/openerp/openerp/openerp/tools/safe_eval.py", line 241, in safe_eval return eval(test_expr(expr, _SAFE_OPCODES, mode=mode), globals_dict, locals_dict) File "", line 1, in <module> File "/home/openerp/openerp/openerp/osv/orm.py", line 374, in function_proxy return attr(self._cr, self._uid, [self._id], *args, **kwargs) File "/home/openerp/openerp/openerp/addons/mrp/mrp.py", line 879, in test_if_product boms = self._action_compute_lines(cr, uid, [production.id]) File "/home/openerp/openerp/openerp/addons/mrp/mrp.py", line 634, in _action_compute_lines res = bom_obj._bom_explode(cr, uid, bom_point, factor / bom_point.product_qty, properties, routing_id=production.routing_id.id) File "/home/openerp/openerp/openerp/addons/mrp/mrp.py", line 328, in _bom_explode factor = _common.ceiling(factor, bom.product_rounding) AttributeError: 'module' object has no attribute 'ceiling'

Am having this same problem. Did you manage to fix it?

Cyrus Waithaka
on 6/22/14, 9:47 AM
0
Cyrus Waithaka
On 9/14/14, 11:18 AM

I had the same issue. In my case, I realized the module that I was using had a bug. I copied the same module from another computer that I had set up earlier and replaced. Try this one instead https://www.dropbox.com/sh/opzp6h50dr9t20k/AAAAvXOw7RUn_wCurm1uweZ0a?dl=0

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 5/16/14, 2:03 AM
Seen: 1278 times
Last updated: 3/16/15, 8:10 AM