Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Traceability Problem

By
Geoff Kimpton
on 10/12/15, 2:49 AM 419 views

With incoming goods A warning that I must enter a serial number is displayed followed by a field to enter the s/no.

However, It does not work on sales. No message & no field to enter the s/no.

In products > inventory > Lots I have tried both "full lots traceability" and "track incoming lots" + "trtack outgoing lots" Together.

Still the same.

Any ideas please?

Yes to all. Ticked in settings, turned on in options. I sell new machines with individual serial numbers which are neccisary for warranty registration/ tracking.

Geoff Kimpton
on 10/12/15, 3:13 PM

Hi this is not an answer but a comment on the delivery order lot functionality that may be relevant. I have found that the delivery order works as Eric said in that you enter the lot number when you 'transfer' the order. But there is no validation that the lot exists or there is sufficient stock on that lot to despatch. In fact you can put anything into the 'lot' column and Odoo will create the lot for you if it doesn't exist. This behaviour  makes no sense when you are doing traceability as you need to trace through your own processes and a simple keying error at despatch will destroy this. I hope this helps and if anyone knows a way to validate the lot number and the stock on the lot on a sales delivery order then please let me know. Dave

Dave Barratt
on 10/29/15, 9:16 AM
0
Eric Decock
On 10/13/15, 4:05 AM

The serial No should be encoded during outgoing transfer operation.

Go to >Warehouse>All operations>click on Delivery orders

Then select the WH/OUT row corresponding to your sale order

Result: transfer operation is displayed with stock moves and availability quantity

Then click on 'Transfer'

The system displays transfer details with products to move

Serial no can be encoded on each row (last column).

You can create s/no beforhand. Go to >Warehouse>Traceability>Serial number and create new entries

Serial numbers are then proposed during transfer operation.

If you don't have the menu Traceability then it can be that you have a missing app in the config.

Hope this will help you...

Thank you for the reply. I dont get a WH/Out row so it looks like a configuration problem. The goods receiving routine does force specifying a ser. no. so I do have stock on hand with ser. no`s allocated. I do have Traceability. "serial numbers" Brings up a list of products with the individual serial numbers assigned to them. I have been through all the configuration settings & they all seem to have a basic default setting that should work.

Geoff Kimpton
on 10/13/15, 8:00 AM
0
Dr Obx
On 10/12/15, 9:43 AM

Do you need those numbers ?

Is this option "ticked" in Settings/Traceability

Track lots or serial numbers (ticked)

If you don't need it, just turn it off and check.

Check if those fields are hidden (invisible) ?


 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/12/15, 2:49 AM
Seen: 419 times
Last updated: 10/31/15, 1:02 PM