Odoo Help

1

Timeout in Search with a lot of product

By
Jorat
on 8/13/13, 9:18 PM 823 views

Hi,

we have 85000+ products mainly because we have many variable for the same product. Multiple width, height and material which translate in a lot of product. Our problem is that with that when we try to make a search using the name field, it timeouts. I tracked down the psql request and when I run the request in the psql console, it never end. The request is the fallow:

SELECT "product_product".id FROM "product_product","product_template" WHERE ((product_product."active" = 'True') AND ((product_product."id" in ((SELECT res_id FROM ir_translation WHERE name = 'product.product,name' AND lang = 'en_US' AND type = 'model' AND value ilike '%SAM-A%') UNION (SELECT id FROM "product_product" WHERE "name" ilike '%SAM-A%'))) OR (product_product."default_code" ilike '%SAM-A%'))) AND (product_product.product_tmpl_id = product_template.id) AND (((product_template."company_id" in (1))  OR  (product_template."company_id" in (1)))  OR  product_template."company_id" IS NULL ) ORDER BY default_code,name_template limit 100

There's definitely a problem with the request. Anyone got suggestion?

EDIT:

I have been able to fix my problem by changing the code inside osv/expression.py

0
Marco Di Francesco
On 11/15/13, 10:23 AM

I tried this fix and works very well. h_t_t_p_s://code.launchpad.net/~openerp-dev/openerp-web/6.1-opw-574218-xal/+merge/10737

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/13/13, 9:18 PM
Seen: 823 times
Last updated: 3/16/15, 8:10 AM