Odoo Help

1

Timeout error with nginx

By
Paulo Matos‏
on 7/25/15, 7:20 AM 8,798 views

Hi there.

After install nginx and setup reverse proxy for my instance, I am gettings a timeout error whille installing a module.

I have tested directly by instance IP address and it works fine.

The message is:

XmlHttpRequestError Gateway Time-out

<html>

<head><title>504 Gateway Time-out</title></head>

<body bgcolor="white">

<center><h1>504 Gateway Time-out</h1></center>

<hr><center>nginx/1.4.6 (Ubuntu)</center>

</body>

</html>

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->


Can anyone help me please.

Thank you in advance


8
Axel Mendoza
On 7/25/15, 3:21 PM

This happens because of nginx need a timeout to know if the servers proxied is processing or not the request. You can increase it to match your needs. I use this value for Odoo in nginx "location /"

proxy_read_timeout 300000;

Thank you Axel. It solved my problem.

ThinkOpen Solutions (Angola), Paulo Matos‏
on 7/25/15, 5:13 PM

Thank you Axel. This solved my problems importing large CSV files to Odoo while using NGINX HTTPS Proxy.

Cliff Kujala
on 12/13/16, 7:38 PM

I'm glad that this are solving problems

Axel Mendoza
on 12/15/16, 12:34 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 7/25/15, 7:20 AM
Seen: 8798 times
Last updated: 12/9/15, 5:13 AM