Odoo Help


Three times the address in Quotations/Orders

Laurent ROCHE
on 12/1/14, 1:02 PM 1,166 views


I am using the Odoo SAS version.

In the PDF document generated for quotations and orders, the adress is printed 3 times.

Once as the document address (same as in a letter) on the top right of the document.

Then in left part of the document, a Shipping address and an Invoice address is printed, with again the same details as in the first address. I don't need these two extra addresses and they don't get printed on the invoice.

How can I remove the Shipping address and the Invoice address from the quotation and order documents ?

I have read that I am supposed to edit the file /addons/sale/report/sale_order.rml but how can I do that with the SAS version ?





Mariusz Mizgier

--Mariusz Mizgier--
| 4 1 7
SOPOT, Poland
--Mariusz Mizgier--

OpenERP developer

Mariusz Mizgier
On 12/1/14, 1:51 PM

If you are on SAAS version, try logging in with user, which has technical features turned on, then going to Settings ->Technical -> Reports -> Reports, find Quotation / Order and click on Search associated QWeb views. When you open report_saleorder_document, you will see the definition of your report - try to remove unnecessary lines and then printing your quotation - that should work just fine.

Jeff Beidler
On 12/1/14, 1:41 PM

I think RML is deprecated.  Your best bet would probably be to create a custom module, inherit the view you wish to override (change), and make your changes in XML.  If you're not familiar with module creation, here is a link to get you started:


You can find the name of the view to override by turning on debug mode (go to About Odoo and click "Activate the developer mode") and then go to the view you want to change.  Choose "Manage Views" from the debug menu list, and it should steer you in the right direction.

Laurent ROCHE
On 12/1/14, 2:15 PM

@Mariusz Mizgier:

I don't have the menu "Settings => Technical => Reports" available with my admin user !

What rights should the user should have to be able to get the Reports command ?

Does your user have Technical Features selected?

Currenda Sp. z o.o., Mariusz Mizgier
on 12/1/14, 2:22 PM

Well, i just realised, that saas version does not support qweb reports, as far as I saw on the runbot - that solution will not work then. Have you tried solution posted https://www.odoo.com/forum/help-1/question/how-to-customize-invoices-in-odoo-online-53249

Currenda Sp. z o.o., Mariusz Mizgier
on 12/1/14, 2:24 PM

Jérémy Kersten (jke)

--Jérémy Kersten (jke)--

| 3 3 5
Jodoigne, Belgium
--Jérémy Kersten (jke)--

Jérémy is a member of the core R&D team since september 2013. He developed several projects for OpenERP version 8 including the eCommerce, the Google Calendar synchronization and the new product variants/configurator. Now, he manages Odoo website and themes for saas.

Jérémy Kersten (jke)
On 12/1/14, 2:49 PM


The migration to V8 for saas are in progress... your are always not in V8 (version which support Qweb) but that will be probably for the next days...

If you need to edit today you report, you need to use the "OpenERP Designer" to load your report in OpenOffice... You can find more info here : https://www.odoo.com/fr_FR/forum/help-1/question/openerp-online-what-are-the-parameters-for-the-report-designer-or-the-thunderbird-plugin-4900 (response from Denix Ledoux (dle))

If your report is not yet customized, I suggest you to wait the Qweb version which will be editable online via the website editor.


About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 12/1/14, 1:02 PM
Seen: 1166 times
Last updated: 3/16/15, 8:10 AM