Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

There is no default shop for the current user's company!

By
daouda
on 3/26/13, 9:30 PM 4,811 views

Hi, I created a sub-company in my database and i was creating a sale order when i suddenly got this error. "There is no default shop for the current user's company!" I don't know what to do. I am in v7. Thanks a lot

6

IBS

--IBS--
1302
| 4 5 8
Tétouan, Morocco
--IBS--

For more informations about IBS, please visit our website at www.ibs-na.com.

For a specific questions, collaboration or help, please send us an email to support@ibs-na.com

IBS
On 3/26/13, 9:55 PM

Go to Sales->Configuration->Shop and create one for your new company.

You can then select it when you create the Sale Order

Note:

  • In Settings -> Users -> Users make sure that Manage Multiple Locations and Warehouses ( which is under Access Rights ) is checked for your account.
  • In Settings->Configuration->Sales, make sure Manage multiple shops is checked.

it works. I don't know what really happen but i suddenly see shop menu in sale->configuration->shop. and i did what you told in your first sentence. Thanks a lot KarimFor Spending all this time for me.

daouda
on 3/27/13, 8:06 PM

No problem :-) I am glad it worked.

IBS
on 3/27/13, 8:14 PM

It appears with the module point_of_sale.

Jairo Llopis
on 4/25/14, 7:14 AM

There is no «Manage multiple shops» in «Settings->Configuration->Sales».

Pascal Tremblay
on 10/18/14, 5:41 PM

In Odoo, «Manage multiple shops» is in «Setting->Configuration->Warehouse»

Pascal Tremblay
on 10/18/14, 5:44 PM
0
Mind And Go
On 1/1/14, 6:29 AM

Hy,

I had the same issue. I solved it by installing point of sale and desinstalling it just after. It's like if a configuration has been deleted. Now it works,

regards

0
Didier
On 7/22/13, 6:15 PM

I have the same trouble after resetting several time the data base : it is impossible to make a quote. - I create a user - I create a child company - I affect the user to the child company

Then when making a quote (registered as the user for the child company), I have : "There is no default shop for the current user's company!"

Then I followed the Karim advice : Please give your account administrative privileges and enable Technical Settings in the Access Rights page, after that go to Settings - Technical - User Interface - Menu Items, search for Shop and let me know what you find, especially what you see in Groups when you open the item.

In the group I did add the user.

But the same impossibility to make a quote : "There is no default shop for the current user's company!"

I am glad to read that for daouda, it worked. She suddenly see the "shop menu" in sale->configuration->shop. But for me no such of luck. That's very odd an erratic. The only item I can see in this menu are : Sales Teams Contacts Segmentation Unit of Measure Categories Address Book Phone Calls Calendar Products Leads & Opportunities

Didier
on 7/22/13, 6:16 PM
0
daouda
On 3/27/13, 7:19 AM

Thanks karim, but there is no shop at sales->configuration, what i see is sale teams, segmentation and things like that

In Settings - Users - Users make sure that Manage Multiple Locations and Warehouses ( which is under Access Rights ) is checked for your account.

IBS
on 3/27/13, 10:14 AM

I checked it but still no works

daouda
on 3/27/13, 10:32 AM

Can you take a screenshot of the user Access Rights page? you can upload it to imgur.com

IBS
on 3/27/13, 10:39 AM

Screenshot already uploaded and available in this link http://imgur.com/AFmmzYu

daouda
on 3/27/13, 12:02 PM

Please give your account administrative privileges and enable Technical Settings in the Access Rights page, after that go to Settings - Technical - User Interface - Menu Items, search for Shop and let me know what you find, especially what you see in Groups when you open the item.

IBS
on 3/27/13, 6:17 PM

okey wait a minute. Did you see the screenshot?

daouda
on 3/27/13, 6:20 PM

yes i did it and i found shop, And i cliked. the results is in this screenshot http://imgur.com/IUKRC04

daouda
on 3/27/13, 6:31 PM

I saw the first screenshot, for now I think the problem is not from there. Please go to Settings - Users - Groups, search for Manage Multiple Locations and open the result you find, let me know if your username is in the Users list.

IBS
on 3/27/13, 6:34 PM

the user is on the list

daouda
on 3/27/13, 6:49 PM

I think I figured it out, please check the last note in my answer, I updated it.

IBS
on 3/27/13, 7:16 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/26/13, 9:30 PM
Seen: 4811 times
Last updated: 3/16/15, 8:10 AM