Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

The period is invalid. Either some periods are overlapping or the period's dates are not matching the scope of the fiscal year.

By
kim
on 6/18/13, 10:11 PM 3,444 views

My Fiscal Years i put cross year which is 1/7/2012- 30/6/2013 after i save. I go set default tax from Settings> Configuration > Accouting it show this warning message

"The period is invalid. Either some periods are overlapping or the period's dates are not matching the scope of the fiscal year."

but when i change to like in same years will no problem. do they have any solution for this problem?

0
Virali
On 4/26/16, 3:09 AM

Hii kim,

I have same issue while creating new database and installing my module. got error.

-- in depends modules - sale, account 

0
Mariano Ruiz
On 10/9/14, 3:38 PM

I had the same problem creating a new database with the demo data.

Solution: restore the file 'addons/account/demo/account_demo.xml' from the Git repository to the revision eed1a93 before install the account module.

0

Kevin McMenamin

--Kevin McMenamin--
804
| 5 2 6
Auckland, New Zealand
--Kevin McMenamin--
Kevin McMenamin
On 6/19/13, 12:27 AM

I found this same problem when setting up a new database - one of the set up wizards is getting confused. I resolved by deleting the year/periods and let the system set up as part of the wizard, then change as required once all the required set up is done.

After i deleted the year/periods and how to let system set up as part of the wizard?

kim
on 6/19/13, 12:51 AM

either it will do it as part of your accounting setup process, or if it does not you can just re-create under accounting/configuration

Solnet Solutions Limited, Kevin McMenamin
on 6/19/13, 12:54 AM

tested still the same no matter i create new database also the same, still get the same error.

kim
on 6/19/13, 1:47 AM

so have you deleted the periods and year and then finished your set up?

Solnet Solutions Limited, Kevin McMenamin
on 6/19/13, 1:50 AM

yup i deleted periods and year after that recreate and also when create new database i directly install accounting and setup the periods and year also is not working

kim
on 6/19/13, 3:58 AM

what you need to do is 1) install the new database 2) delete the periods/years created 3) complete the accounting setup, then 4) go back and check/update your years/periods. If you have followed these steps and still having a problem then I am not sure what is happening.

Solnet Solutions Limited, Kevin McMenamin
on 6/19/13, 6:14 PM
0
Steven Segers
On 2/2/14, 3:42 AM

There is a bug-report on launchpad about this problem: https://bugs.launchpad.net/openobject-addons/+bug/1103854. The last comment points out that it was fixed on 2013-05-08. If you still run into the issue (like I just did) you need to update the account module.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 6/18/13, 10:11 PM
Seen: 3444 times
Last updated: 4/26/16, 5:16 AM