Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

System tells me to have coffee all the times :(

By
Faisal
on 3/24/13, 8:38 AM 1,522 views

Hi, I do not drink coffee and system for any small change or addition goes into configuration and then insists that "I take coffee" ;) and does not stop even if I take it. Any idea why it tells me for coffee again and again and how I can make it work without this offer? Cheers. Note: This is just to get you an "idiot's" view of the situation.

The servers must be addict to coffee! They tell me the same recommendation.Nobody is perfect:)

AD LIBITOM, michel Guénard
on 3/24/13, 9:29 AM

What do your log files show when this occurs?

Martin
on 3/25/13, 7:20 PM

when using Chrome browser for the action "Validate closing & post entries" of a current POS session, after - let say 7 minutes - XmlHttpRequestError Gateway Time-out <html> <head><title>504 Gateway Time-out</title></head> <body bgcolor="white"> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx/1.2.1</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly erro

AD LIBITOM, michel Guénard
on 3/25/13, 8:43 PM

and a different log when using Firefox!

AD LIBITOM, michel Guénard
on 3/25/13, 8:45 PM

that is on the client side, what do the server logs show?

Martin
on 3/25/13, 10:31 PM

No idea; because I am using the OpenErp.com online services. Screen captures have been sent to support! see also http://help.openerp.com/question/1058/validate-closing-post-entries-error/

AD LIBITOM, michel Guénard
on 3/26/13, 7:09 AM

Can you take a look to what is happening in odoo logfile? If you decide to have coffee whenever Odoo tell you to do so... take care with caffeine....

Daniel Blanco
on 7/22/15, 7:08 PM

I see you are using Nginx and you have 504 errors. Nginx will close backend connect if the response did not comeback in time, I can't recall the default (I think it is 60 secs), you need to set it higher. Try access direct to your Odoo without Nginx and see if how long you need to wait . Set the proxy_read_timeout to higher in nginx , so that you dun get 504 timeout. If after have a few rounds of coffee, your request is still not working...maybe its you internet that is problematic.

Gavin Yap
on 7/23/15, 1:21 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/24/13, 8:38 AM
Seen: 1522 times
Last updated: 7/23/15, 1:21 AM