Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


SyntaxError: JSON Parse error: Unexpected EOF

Alex Gallien
on 9/12/14, 4:46 PM 6,394 views

EDIT: Figured out the issue here was likely with Ubuntu 14 and wkhtmltopdf, creating a new VM with Ubuntu 12 instead solved the problem.


I recently installed a new instance of OpenERP v7.0, and am getting an error when trying to install a custom report module: SyntaxError: JSON Parse error: Unexpected EOF:

Traceback (most recent call last):
  File "/opt/openerp/odoo/openerp/netsvc.py", line 296, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/odoo/openerp/service/web_services.py", line 654, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/odoo/openerp/service/web_services.py", line 760, in exp_report_get
    return self._check_report(report_id)
  File "/opt/openerp/odoo/openerp/service/web_services.py", line 738, in _check_report
    netsvc.abort_response(exc, exc.message, 'warning', exc.traceback)
  File "/opt/openerp/odoo/openerp/netsvc.py", line 71, in abort_response
    raise openerp.osv.osv.except_osv(description, details)
except_osv: (u"list index out of rangeparagraph text u'<para></font></para>' caused exception\nhandle_pageBegin args=()", (<type 'exceptions.IndexError'>, IndexError("list index out of rangeparagraph text u'<para></font></para>' caused exception\nhandle_pageBegin args=()",), <traceback object at 0x7fd88ef03290>))

Any idea why this might be? It worked perfectly in my other instance. One thing that might have caused it is that I had a v7 saas-5 instance on the same server, but I removed the git repo and reinstalled. Should I nuke/pave the VM and try again? The other thing I noticed is that my old version (installed by someone else) is at Version 7.0-20131113-002526, where my new one says just Version 7.0 - not sure if that could be causing it too. Any insight would be greatly appriciated!

'' is invalid XML/HTML. Could be caused by a bug in the custom module that doesn't handle empty data sets well? Since you mentioned it's a new instance, I don't know how much data you've migrated into the server. I don't think nuking the VM is necessary. What's the custom module, and where's the source code for it?

Brett Lehrer
on 9/13/14, 12:03 PM

Note that my (para)(/font)(/para) tags were stripped from the beginning of the comment.

Brett Lehrer
on 9/13/14, 12:05 PM

http://pastebin.com/X5Z0xpex is the xml for one of my reports. There is another that is very similar. What is strange is that it is working on my old version 7 install, but that was done by someone else so I am not sure if there were some differences in the way that it was installed. I ran the code through an xml validator on w3 schools and it turned up with no errors. Really not sure what's going on here.

Alex Gallien
on 9/15/14, 3:53 PM
On 6/28/16, 7:28 AM

Hi Guys,

I am facing the same issue. I am using Odoo7 on Ubuntu 14. It worked well when I am running the application on Ubuntu 12. Onc I shifted my application to Ubuntu 14, the sale order report is not loading and the email template in which sale order is attached, is showing the following error.

list index out of rangeparagraph text u'<para></font></para>' caused exception


When I am trying to download the sale order, it is showing the following error.

Uncaught SyntaxError: Unexpected end of JSON input

Can anybody help me with a solution.

Thank you.



On 7/16/15, 3:53 PM

I also faced this error. Please help.

When i try to print invoice that has some special character(crotian language) in customer name. It gives me this.

"SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data"

This is my log :

return self.app(environ, start_response)

File "/opt/odoo/openerp/http.py", line 1441, in dispatch

return response(environ, start_response)

File "/usr/lib/python2.7/dist-packages/werkzeug/wrappers.py", line 1200, in __call__

app_iter, status, headers = self.get_wsgi_response(environ)

File "/usr/lib/python2.7/dist-packages/werkzeug/wrappers.py", line 1190, in get_wsgi_response

return app_iter, self.status, headers.to_wsgi_list()

File "/usr/lib/python2.7/dist-packages/werkzeug/datastructures.py", line 1185, in to_wsgi_list

return [(k, v.encode('latin1')) for k, v in self]

UnicodeEncodeError: 'latin-1' codec can't encode characters in position 34-38: ordinal not in range(256)



| 5 4 7
Bangalore, India

Techno-Functional Associate with 6+ years of experience in Odoo (formerly known as OpenERP).

On 9/15/14, 10:16 AM

Check the .openerp-serverrc file... which will be present in Home folder(by default)...

You are trying to run Openerp 7 but your server is pointing to Odoo server...

Once I am in there how do I know which server it is pointing to? I don't see any fields that indicate that.

Alex Gallien
on 9/15/14, 1:45 PM

It is a hidden file... use control + H

From: Alex Gallien <agallien@informationofficer.com>;
To: deep <deepa4lok@yahoo.com>;
Subject: Re: False
Sent: Mon, Sep 15, 2014 5:45:52 PM

Once I am in there how do I know which server it is pointing to? I don't see any fields that indicate that.


Alex Gallien
Information Officer LLC

Sent by OpenERP S.A. using Odoo about Forum Post False
on 9/15/14, 1:52 PM

I accessed the file without issue - I just don't know which of the fields tells me which server it is pointing to. I am beginning to think that it is my installation that is broken, so I am just going to start over. Thanks for the help though.

Alex Gallien
on 9/15/14, 1:54 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)


Asked: 9/12/14, 4:46 PM
Seen: 6394 times
Last updated: 6/28/16, 7:28 AM