Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

.sxw to .rml convertion problems can anybody help?

By
Sreedath Namangalam
on 4/25/13, 10:21 AM 2,108 views

on converting .sxw to .rml the report is not showing some lines in table. is it because of the problem with the conversion scripts?

0
klacus
On 4/25/13, 11:30 AM

You can add a line manually to rml. I think better if you forget the sxw...

example a margin line

    <lines> 15 65 574 65</lines>
    <lineMode width="20"/>

position X=15 point to 574 point Y=65 point

If you put between here, like this

<pageTemplate id="first">
    <pageGraphics>
        <lines> 15 65 574 65</lines>
        <lineMode width="20"/>
    </pageGraphics>             
</pageTemplate>

you can see the line all of the page.

If you put between the story element in this case you can see just for the actual page.. Hope that's helps to you, or sorry about if this thinks is not new for you :-)

0

Keyur

--Keyur--
1165
| 4 4 8
Ahmedabad, India
--Keyur--

Odoo Expert

Keyur
On 4/25/13, 11:06 AM

Hi, just paste your error in comment so anyone can understand where exactly the error is, if possible & helpful. The simplest way to solve the problem is to check code line by line. For example do minimum code in sxw file & convert it into rml then generate the report if still there is a problem minimize code in your sxw file and then convert it into rml & then if it works it's fine, by doing this you are able to know where exactly the error is.

To bold font in sxw file you need to keep separate format for bold font sentence & for normal one.Suppose the heading of the report is Partner Report then keep different format(font style:Liberation Serif) & for table data keep different format style(font style:Liberation Sans)

To apply color on your fonts you need to change in your like this

<font color="white"> </font>

You can specify "blue" as a color. And other way is

<paraStyle name="P1" fontName="Helvetica-Bold" fontSize="2.0" textColor="#ffffff"/>

ya i tried doing that. no error is there. it is producing the reports. but some functions like bold, color are not working as in the sxw file. i have this problem even when trying with minimum code

Sreedath Namangalam
on 4/25/13, 11:18 AM

Hi this is not a error, without your sxw or rml its difficult to analysis what is error

jamesbale
on 4/25/13, 11:26 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/25/13, 10:21 AM
Seen: 2108 times
Last updated: 3/16/15, 8:10 AM