Odoo Help

1

Switching database in login screen gives Internal server error

By
ankita
on 5/6/15, 8:07 AM 1,157 views


Impacted versions:

8.0 at least

Steps to reproduce:

Open a runbot

Before login change database to uuid-whatsoever-base

Change back database to uuid-whatsoever-all

Current behavior:

HTTP 500 Internal server error

Reloading the page fixes the problem

Seems to happen only on the login page when website module is not installed

Logs give

Traceback (most recent call last):

File "C:\Program Files (x86)\Python27\lib\site-packages\werkzeug\serving.py", line 177, in run_wsgi

execute(self.server.app)

File "C:\Program Files (x86)\Python27\lib\site-packages\werkzeug\serving.py", line 165, in execute

application_iter = app(environ, start_response)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\service\server.py", line 281, in app

return self.app(e, s)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\service\wsgi_server.py", line 216,

in application

return application_unproxied(environ, start_response)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\service\wsgi_server.py", line 202, in application_unproxied

result = handler(environ, start_response)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\http.py", line 1280, in call

return self.dispatch(environ, start_response)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\http.py", line 1254, in call

return self.app(environ, start_wrapped)

File "C:\Program Files (x86)\Python27\lib\site-packages\werkzeug\wsgi.py", line 588, in call

return self.app(environ, start_response)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\http.py", line 1421, in dispatch

result = ir_http.dispatch()

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\addons\base\ir\ir_http.py", line 168, in dispatch

return self._handle_exception(e)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\addons\base\ir\ir_http.py", line 132, in _handle_exception

attach = self._serve_attachment()

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\addons\base\ir\ir_http.py", line 104, in _serve_attachment

request.cr, openerp.SUPERUSER_ID, domain,

File "C:\Program Files (x86)\Python27\lib\site-packages\werkzeug\local.py", line 338, in __getattr

return getattr(self._get_current_object(), name)

File "C:\Users\nicolas\Documents\Progs\GitHub\odoo\openerp\http.py", line 240, in cr

self._cr = self.registry.cursor()

AttributeError: 'NoneType' object has no attribute 'cursor'

Expected behavior:

Flawless switch between databases

This issue has been reported at https://github.com/odoo/odoo/issues/6100 - did you copy and paste your post from there?

Bista Solutions US, Ray Carnes
on 5/13/15, 12:42 AM
3
Rakesh Sindhav
On 5/18/15, 7:36 AM

I create PR regarding this. It will fix your problem.

Link: https://github.com/odoo/odoo/pull/6705

Thanks Rakesh Sindhav , Its working.

ankita
on 5/27/15, 2:00 AM
0
Gaurav Sahu
On 5/9/15, 2:37 AM

Clear cache memory of browser or delete history 

Still not solved

ankita
on 5/11/15, 7:24 AM
0

If you refresh page work fine too.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 5/6/15, 8:07 AM
Seen: 1157 times
Last updated: 9/22/15, 2:31 AM