Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

supplier/customer check mark fields missing while importing companies

By
E.M.
on 5/30/15, 7:07 AM 619 views

While trying to import companies in Odoo 8 it seems that "supplier" and "customer" fields are missing.

They do not appear in the combo box to select destination import field.

1

Ray Carnes

--Ray Carnes--
15677
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 5/30/15, 4:56 PM

 Company in Odoo has two meanings: 

  1. An organization - with a set of partners (leads, customers, suppliers and employees), users (logins) and stock of products with a separately managed set of accounts.  This type of company installs Odoo!

  2. A partner that isn't a person - a 'type' of Customer or Supplier to support B2B (as opposed to B2C) transactions. An entity that buys from (or sells to) a type (1) Company. This type of company is sent emails and PDF's from Odoo!

Companies (type 1) are imported via

  • Settings --> Companies --> Companies

Partners with "Company = TRUE" (type 2) are import via:

  • Messaging --> Contacts (default CUSTOMER=True, COMPANY=False unless overridden in your import file) 

  • Sales --> Sales --> Customers (default CUSTOMER=True, COMPANY=False unless overridden in your import file)

  • Purchases --> Purchase --> Suppliers (default SUPPLIER=True, COMPANY= False unless overridden in your import file)


To your question - which menu are you at when you are trying to import?  You won't see Supplier and/or Customer as an option for type (1).

 

 


 

0
E.M.
On 5/31/15, 3:22 AM

Ray's answer has clarified everything, I did not properly understand the difference: I was using "companies" (Settings -> Companies -> Companies) while I was actually trying to import "partners".

I have repeated the import operation using (Sales -> Sales-> Customers) and Supplier/Customer fields have been recognized.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/30/15, 7:07 AM
Seen: 619 times
Last updated: 5/31/15, 3:27 AM