Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Source Install on Windows 10 is not Working

By
Mathan
on 12/21/15, 3:20 AM 4,001 views

Dear Developers,

I am new to python and new to Odoo. As per the documentation provided by Odoo. I tried installing the odoo 9.0 on windows 10. but its not working. here are the steps i followed.


1) Installed python 2.7.9 on c drive ( C:\Python27)
2) Installed PostgreSQL 9.4 C:\Program Files\PostgreSQL
3) created New login role with super user privilege user: odoo and pwd: odoo

4) on the requirements.txt - as said in the docs, installed those in the path 

C:\odoo> C:\Python27\Scripts\pip.exe install -r requirements.txt

5) Installed node.js, and installed C:\> npm install -g less less-plugin-clean-css


After all this, I configured config file - openerp-server.config with following lines.

addons_path = C:\odoo\openerp\addons

db_host = localhost

db_maxconn = 64

db_name = False

db_password = odoo

db_port = 5432

db_user = odoo

pg_path = C:\Program Files\PostgreSQL\9.4\bin

and saved it.

After all this, I opened Command prompt and gone to C:\odoo and run odoo.py

and opened browser with localhost: 8069 after loading few seconds i just get Internal error only.

please Guide me  what mistake i did and why its not working? I was trying this for past 3 days. not able to find solution. i tried installing many times.

I am beginner so unable to trace whats happening. I want to learn and develop from the odoo for my project. 

Please help me..

Screenshot of cmd: http://postimg.org/image/8vctm3j57/


Looking for solution. please..


Please check your log file which should be found at a location like /Program Files/odoo/server/opener-server.log.

Ermin Trevisan
on 12/21/15, 3:42 AM

@ Ermin Trevisan - I downloaded the source zip from this link. https://nightly.odoo.com/9.0/nightly/src/odoo_9.0.latest.zip

There is no server folder on it. There is no log file as you said. 

Any other way? 

Mathan
on 12/21/15, 4:32 AM

You should be able to locate your log file, most probably it has the name odoo-server.log, maybe openerp-server.log. I do not have a Windows installation, but I'm sure you can find it when you look for it seriously. Without reading the log file it is not possible to identify the error and its reason. As a side note: please do not hijack other threads. As a second side note: you should consider installing Odoo on a Ubuntu 14.04 LTS server, this is the most popular deployment option and therefore your chances to get help are much better.

Ermin Trevisan
on 12/21/15, 8:52 AM

actually, i used the source zip file and i couldn't able to find the log file in it. anyway, i will try to find it.

by the way, am not trying to hijack any threads. am just tried to find the solution from the person who known windows platform.

and another question Is it possible to install on kali os platform just like ubuntu?


Mathan
on 12/21/15, 12:08 PM

You will find your log file in your installation, not in the source zip file. Please read the forum guidelines. Hijacking is hijacking, the reason doesn't matter. And if you have a new question, post a new question. Why would you want to install Odoo on a penetration testing platform such as Kali Linux? If you want to get familiar with Odoo and you are not familiar with setting up and managing servers, stick to the most common options, in this case use Ubuntu 14.04 LTS. Of course you can install Odoo on Kali Linux also, but you will for sure not find any reasonable help with it.

Ermin Trevisan
on 12/22/15, 3:21 AM
0
Ankit Goel
On 5/7/16, 1:05 PM

As i can see in your CMD file, the database is default@default which means odoo is accessing the postgres user which it shouldnt as defined in the code itself.

Try using the following lines in CMD tab

cd YOUR_ODOO_LOCATION (eg: cd C:\Users\Administrator\Documents\odoo-9.0)

python odoo.py -w YOUR_DB_PASSWORD -r YOUR_DB_NAME  --db_port YOUR_DB_PORT --db-filter=YOUR_DB_NAME$ (eg. python odoo.py -w odoo -r odoo --addons-path=addons --db_port 5433 --db-filter=odoo$)

I dont know if this would work but you could try none the less. Worked for me. But i had not edited the config file. You can make a .bat file of these commands and let them run rather than typing them again and again.

0
Mathan
On 12/22/15, 3:35 AM

Okay. Thanks for your comments.  

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/21/15, 3:20 AM
Seen: 4001 times
Last updated: 5/7/16, 1:05 PM