Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


[SOLVED] Workflow action/signal has no effect

Fernando La Chica Mera
on 5/10/16, 11:49 AM 342 views

Hello, I have a problem changing a record status using the workflow. When I created it, I had a problem with user permissions and creator could not read the model "mail.notification". This seems to have caused an unwanted record that I want to change state side effect.

The affected object is a "hr.expense.expense" and when I want to change state does not give me error but I do not it changes state. It seems as if the associated workflow instance was not properly created.

Any solution?



I solved the problem. Debugged on my development machine I have observed that for events activity workflow run is necessary to find records on 'wkf.workitem' with state = 'active' and the instance related with the registry on 'hr.expense.expense'.

These records were created with errors and were in a state workitem 'running'. I have changed and now runs the workflow.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 5/10/16, 11:49 AM
Seen: 342 times
Last updated: 5/11/16, 6:38 AM