Odoo Help


{Solved} Printing error: TypeError: this.contentDocument is null

Ev'Art Creativ
on 11/17/15, 5:00 AM 2,429 views

Hello :) i'm a happy user of the wonderfull Odoo V9 community edition :)

I'm using it on a Debian Jessie serveur with Nginx where Odoo was instaled thru the nighly builds Odoo package.

Everything is working fine except when i want to print.

When i would print a quote, an invoice, on someone else i always have this error:


TypeError: this.contentDocument is null


Retraçage :





in another way when i would send a document by mail i have this error:


Wkhtmltopdf a échoué (code d'erreur : -6). Message : The switch --header-spacing, is not support using unpatched qt, and will be ignored.The switch --header-html, is not support using unpatched qt, and will be ignored.The switch --footer-html, is not support using unpatched qt, and will be ignored.QXcbConnection: Could not connect to display


is someone have an idea to where i should look to solve there issues ?

thank you very much by advance for your help :)

Ev'Art Creativ
On 11/17/15, 7:14 AM

Ok i have solved to issue.

i had installed the jessie package. Which is not the best way.

then I've removed it in root: (that's why there are no "sudo" prefix)

apt-get remove --purge wkhtmltopdf

downloded and installed the last release (at this day) on the official website, installed it, and restart odoo:

cd ~

wget http://download.gna.org/wkhtmltopdf/0.12/

dpkg -i wkhtmltox-

sudo cp /usr/local/bin/wkhtmltopdf /usr/bin/

service odoo restart

all is fine now :)

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 11/17/15, 5:00 AM
Seen: 2429 times
Last updated: 11/17/15, 7:17 AM