Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[solved] Odoo v8 HTML EDITOR & Edit Menu and other buttons

By
M Grmn
on 2/7/16, 5:36 AM 539 views

In version v8, I seem not to be able to use the HTML EDITOR and or EDIT MENU. I can change themes. Also promote link doesn't respond, neither does the mobile button. Install Apps link does work as does remove logo remove default header checkboxes.

When click for example on HTML EDITOR it does direct to  page/themes#advanced-view-editor but nothing happends. No page change nothing.

I installed the latest v8 version using git clone. (only have Website in menu in administration, no Website builder)

Any ideas? Is this a known problem, update available or something on my end (no errors are shown in log file)
----


Thanks Jeremy, restoring original solved button problem. I did replace reg in blockUI to remove warning.


/* old

if (/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery) || /^1.1/.test($.fn.jquery)) {

alert('blockUI requires jQuery v1.2.3 or later! You are using v' + $.fn.jquery);

return;

}*/

if ((/1\.(2\.([3-9]|[1-9][0-9])|[3-9]\.[0-9]*|[1-9][0-9]*\.[0-9]*)/.test($.fn.jquery)) === false ) {

alert('blockUI requires jQuery v1.2.3 or later! You are using v' + $.fn.jquery);

return;

}


It seems that you have a problem with javascript. Launch debug mode (?debug in url) and take a look in your browser console to have the error detail.

Jérémy Kersten (jke)
on 2/7/16, 8:13 AM

Yea did that. Indeed there is a error in jquery.ba-bbq.js (not on front though) blockUI has already been replaced so thats -1. And that said some work, some dont! FF console says: Error: QWeb2: Can't clone undefined template web_editor.dialog.link

M Grmn
on 2/7/16, 8:19 AM

don't worry about the warning of blockui... it just that 11 is little than 8... is just a warning. No need to replace this lib ! Can you retry with the default lib and look if you have always the same error... You can also try to make an update of website module.

Jérémy Kersten (jke)
on 2/7/16, 8:31 AM

Just not funny having the popup of blockUI. already git cloned latest v8 version. v9 doesnt have the problem but has plenty others.

M Grmn
on 2/7/16, 12:29 PM

Also when just installed the notice / warning of blockUI prevents window being reloaded. so it will ask you over and over to set master password and ofcourse new dbname. I could just remove warning code but didn't seem right thing to do. Warning comes up for a reason

M Grmn
on 2/7/16, 12:31 PM

Replacing original blockUI seems to be solution for the buttons.

M Grmn
on 2/7/16, 1:01 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/7/16, 5:36 AM
Seen: 539 times
Last updated: 2/7/16, 1:09 PM