Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[solved] Odoo Sales. Can't see Leads in "my" Leads

By
Laurent
on 8/20/15, 2:28 AM 1,170 views

Hi,

I have a lead which appears in the Direct Sales. I can access to it when clicking on Sales->Sales Teams->Direct Sales/Leads. It is assigned to me (Salesperson is me). And I am the team leader of Direct Sales team.

But I do not see it in my Leads (Sales->Leads, without going through the Direct Sales sales team.)

- Is it normal by default? Why? Any clue of what lead to this?

- How can I have/see it in my Sales?

Context: Very new to Odoo. Using an unmodified v8. CRM and Sales Management modules installed.

Thank you for your help

-- Laurent

0
Laurent
On 8/20/15, 6:07 AM

Is there any way to change/remove this "Unassigned" filter without programming/changing the code?

Thx 

u can go to the search view of crm.lead object and remove this line: "
"<filter string="Unassigned" name="unassigned" domain="[('user_id','=', False)]" help="No salesperson"/>"
this you can do from front end only using "debug mode" or from [settings->technical->user interface->views] and search for crm.lead search view,
but once update the crm module this will be rolled-back to the previous state

Pawan
on 8/21/15, 10:27 AM

Great it works. Not very sustainable in the long term if there are many such changes, but it works. Thx a lot.

Laurent
on 8/21/15, 12:25 PM
1

Pawan

--Pawan--
1267
| 4 3 5
Hyderabad, India
--Pawan--


Pawan
On 8/20/15, 7:51 AM

Laurent,

In Leads Menu, if you select "My Leads" Filter then it will show all the Leads where Salesperson is the logged in user(in your context, its you), so it will show those Leads where you are the Salesperson, and under 'Unassigned' filter those Leads will be shown which does not have any Salesperson.

If you want to remove/change "Unassigned" filter then you have to inherit SEARCH view of crm.lead and then override the "My Leads" filter for ex:

<filter string="My Leads" position="attributes">

        <attribute name="string">MY Test Leads</attribute>

</filter>

Hope it helps

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/20/15, 2:28 AM
Seen: 1170 times
Last updated: 9/9/15, 11:53 AM