Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

[solved] Etherpad in notes with an ssl connection to odoo doesnt load?

By
Tobias Frankl
on 8/9/14, 2:58 PM 2,996 views

Sorry but i didnt find a description how to configure this and I tried a while:

Situation - A odoo instance is running:

With local access http://127.0.0.1:8069 the etherpad on 127.0.0.1:9001 is configured and shown perfectly.

With local access to the same DB wirh https://127.0.0.1 odoo is shown fine, but etherpad inside notes does not load.

The https runs over an nginx with ssl certificate, which works fine. How to configure etherpad to work inside a secure odoo?

how many people here are using etherpad-lite inside odoo?

Thanks in advance.

Edit: Managed with your help. With ssl enabled inside etherpad config and ssl connection to eterpad-lite it works fine. 

Have you installed your etherpad-lite on an dedicated server? Backup is not so convinient with some data outside of the postgres db -> in the mysql-db of the etherpad. So its working and I am not sure about using it in production.... Still I would favour some integrated solution. Thanks for your help :-)

Tobias Frankl
on 8/10/14, 3:14 AM

Hello, I am actually facing the exact same situation. Odoo is hosted with officialy signed SSL certificate. Working properly. Pad is under the sub-domain pad.xxxx.com and with a self-signed SSL certifiacte. Working properly. When logging in odoo, I got a blank screen in the iframe with only one icone to expand the iframe which, if I click on it, opens me a _blank new page with the same icone on the top right. Can you please help me? I am curious on how you managed to solve it. Cheers, H

Haider Alleg
on 1/7/15, 6:41 AM

Me again. Found it. This was just to re-declare the https in the odoo config and re-start the odoo server as well as etherpad one. Everything works now.

Haider Alleg
on 1/7/15, 7:02 AM
1
Mariusz Mizgier
On 8/9/14, 3:09 PM

We use that in production server and there is an issue if you want to load an potentially unsafe content with ssl connection. Browsers (at least Chrome and Firefox) will block any remote-site from loading, when it is running without ssl. You have to run etherpad with https, then add certificate to the browsers' storage and you will be set to go.

0
Billie Mead
On 2/19/15, 1:39 AM

Can anyone point me in the direction of the steps I need to take? I have Odoo instance running under https Nginx successfully but am having the same issues.

I edited etherpad lite settings.json and setup the ssl section to match what is in /etc/nginx/sites-available/site-settings.com

ssl_certificate     /etc/nginx/ssl/cert_chain.crt;
ssl_certificate_key /etc/nginx/ssl/bvc.key;

Restarted all services but no only did it not work in Odoo, then I couldn’t even reach Etherpad at http://104.237.151.145:9001

Do I generate a new self-signed cert just for etherpad? Any other steps? I read someone mentioned updating ssl in Odoo config… many thanks for any pointers.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 8/9/14, 2:58 PM
Seen: 2996 times
Last updated: 3/16/15, 8:10 AM