Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

SMTP outgoing server "Run connect() first" problem

By
Gerardo Galiano
on 3/7/16, 4:21 PM 370 views

I installed odoo 9.0c community on a dedicated server with ubuntu 14.04.
I have an account on register.it for the Mailbox Management.

As recommended by the Register.it guide, in General Settings / Outgoing Mail Servers I wrote:
SMTP server: authsmtp.mydomain.ext
Port: 25
Security: none
Username: smtp@mydomain.ext
Password: mypassword

Obviously mydomain.ext and mypassword have been replaced with the real domain and the real password.

In "general setting", alias domain has been set with the same domain of mydomain.ext

Clicking on "Test Connect" I get: "Test Connection Succeeded! Everything Seems properly set up!"

The problem is that if I try to send an email I get no output, but in "general settings" displays a warning icon and the message: X emails failed, where X in the number of emails that i tried to send. The reason for the failure is: "Run connect () first.".

So I wrote a small python script that uses the same data and that it works properly.


I also tried the same data on a virtual machine server that I created locally with the same version of odoo and ubuntu and sending email is working properly (though the email is sent to the spam folder).

Does anyone have an idea?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/7/16, 4:21 PM
Seen: 370 times
Last updated: 3/7/16, 4:32 PM