Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Sitemap.xml created incorrectly with reverse proxy

Chris Z.
on 7/11/15, 9:54 AM 1,196 views

Using the fresh Odoo installation I configured website, all went fine apart from the fact that sitemap.xml is pointing to localhost:port rather than address defined at web.base.url parameter (it was defined after the website configuration). 

As a site effect each time I login as admin to the system I am redirect to localhost. I setup web.buase.url.freeze to True but is does not help.

I deleted  sitemap.xml from attachments few times other last 2 days but with no improvement.

The system is installed with reverse proxy Nginx.

Anybody has experience with this type of the problem?


Axel Mendoza

--Axel Mendoza--
| 6 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 7/13/15, 4:45 AM

That's a problem of the running type of Odoo server(Gevent, Threaded or Prefork), they have the responsability of correctly handle reverse proxy headers like:



X-Forwarded-Proto or X-FORWARDED-PROTO

to correctly build wsgi environ. You still need to pass those headers from nginx to Odoo server.

Chris Z.
On 7/13/15, 1:08 PM

Indeed I did not setup that part in conf file. Thanks a lot!

I am having this issue. How did you resolve it. What parameter name did you put in the config file? The answer here is not clear enough. Thanks

on 5/1/16, 9:55 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 7/11/15, 9:54 AM
Seen: 1196 times
Last updated: 7/13/15, 1:08 PM