Odoo Help

0

Show VAT (BTW) number of customer on invoices

vat
By
Kenny
on 6/14/13, 11:01 AM 3,968 views

Hi,

Sorry if this question is already answered on the forum but I could not find it... How do I add the VAT number of the customer (BTW number for Belgium) to my invoices? I think this is located here: res.partner.vat but when adding it to in OpenOffice it does not show on a new invoice. This is my data:

[[ (o.partner_invoice_id and o.partner_invoice_id.title and o.partner_invoice_id.title.name) or '' ]] [[ (o.partner_invoice_id and o.partner_invoice_id.name) or '' ]] [[ o.partner_invoice_id and display_address(o.partner_invoice_id) ]] [[ o.partner.vat_id ]]

Hi Kenny, I mean, there is an option of marking/tagging the question as solved. That allwos you to choose, why it is solved, and has an option to appoint the correct answer.

patrick
on 6/16/13, 2:11 PM
1
patrick
On 6/14/13, 11:52 AM

Try o.partner_invoice.vat instead of o.partner.vat_id

The field is called vat, in the table/model res.partner.

o.partner_invoice is the reference to the partner who will get the invoice, I can imagine you want to use the VAT from this account (if the VAT exists).

You want to use o.partner, which does not exist on the object/model sale.order. If you want to use the customer, not the invoice_partner, use o.partner_id.vat

So use o.partner_invoice.vat or o.partner_id.vat

Thank you very much!

Kenny
on 6/14/13, 12:30 PM
0
Kenny
On 6/16/13, 8:17 AM

Answer by Patrick is working.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 6/14/13, 11:01 AM
Seen: 3968 times
Last updated: 3/16/15, 8:10 AM